4

Hi I have successfully built monerod from github source (by this I mean that cmake did not report any errors). However, running make release-test gave me the following output:

Test project /home/<user>/Libs/monero/build/release
      Start  1: hash-target
 1/13 Test  #1: hash-target ......................   Passed    0.28 sec
      Start  2: coretests
 2/13 Test  #2: coretests ........................***Failed  14208.87 sec
      Start  3: crypto
 3/13 Test  #3: crypto ...........................   Passed   27.21 sec
      Start  4: unit_tests
 4/13 Test  #4: unit_tests .......................***Failed   30.31 sec
      Start  5: difficulty
 5/13 Test  #5: difficulty .......................   Passed    0.09 sec
      Start  6: hash-fast
 6/13 Test  #6: hash-fast ........................   Passed    0.02 sec
      Start  7: hash-slow
 7/13 Test  #7: hash-slow ........................   Passed    0.49 sec
      Start  8: hash-tree
 8/13 Test  #8: hash-tree ........................   Passed    0.02 sec
      Start  9: hash-extra-blake
 9/13 Test  #9: hash-extra-blake .................   Passed    0.06 sec
      Start 10: hash-extra-groestl
10/13 Test #10: hash-extra-groestl ...............   Passed    0.05 sec
      Start 11: hash-extra-jh
11/13 Test #11: hash-extra-jh ....................   Passed    0.04 sec
      Start 12: hash-extra-skein
12/13 Test #12: hash-extra-skein .................   Passed    0.01 sec
      Start 13: libwallet_api_tests
13/13 Test #13: libwallet_api_tests ..............***Failed  256.73 sec
77% tests passed, 3 tests failed out of 13

Total Test time (real) = 14524.39 sec

The following tests FAILED:
      2 - coretests (Failed)
      4 - unit_tests (Failed)
     13 - libwallet_api_tests (Failed)
Errors while running CTest
Makefile:127: recipe for target 'test' failed
make[1]: *** [test] Error 8
make[1]: Leaving directory '/home/<user>/Libs/monero/build/release'
Makefile:54: recipe for target 'release-test' failed
make: *** [release-test] Error 2

I was planning to run a full node and use modero-wallet-cli to hold a few XMR (buying them from shapeshift say). Should I not even try, until I get 100% unit test success? or is it likely to run fine after all?. Any advice is appreciated.

$ uname -a 
Linux <hostname> 4.8.0-1-amd64 #1 SMP Debian 4.8.5-1 (2016-10-28) x86_64 GNU/Linux

$ git status 
HEAD detached at v0.10.3.1
nothing to commit, working tree clean
6

It is likely to be fine, with a caveat:

To determine what the failing tests are, you need to run core tests and unit tests manually:

./build/release/tests/unit_tests/unit_tests
./build/release/tests/core_tests/coretests

The unit tests one may be interesting. Or it might be about serialization, which is a known problem in the setup in some cases (Arch Linux IIRC), and not a problem in Monero itself.

The core tests one may be the invalid key image test, fixed in the PR above. If it's just that, all is fine.

If it's anything else, the Monero team wants to know!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.