2

Testing out the new XMR Stak Miner, currently using Wolf's CPU miners. I'm on Ubuntu 16.04, and the build works as in the README, setup the config for my address, and fixed the memory alloc issue here (Failure when using XMR Stak CPU Miner on Linux).

The output I'm getting is:

[2017-04-17 20:22:56] : Connecting to pool pool.minexmr.com:7777 ...
[2017-04-17 20:22:56] : Connected. Logging in...
[2017-04-17 20:22:56] : SOCKET ERROR - invalid address used for login
[2017-04-17 20:22:56] : SOCKET ERROR - RECEIVE error: socket closed
[2017-04-17 20:22:56] : Pool connection lost. Waiting 10 s before retry (attempt 2).

It seems the connection to the pool isn't getting created. Is this my end or the pool's?

There's no issues on the repo or subreddits about the socket error

2

Did you try a different Address or checked your Address if it is correct? I tested it using an invalid address and I got almost the same error. However, valid address works!

[2017-04-18 00:38:10] : MEMORY ALLOC FAILED: VirtualAlloc failed.
[2017-04-18 00:38:10] : Starting single thread, affinity: 0.
[2017-04-18 00:38:10] : Starting single thread, affinity: 1.
[2017-04-18 00:38:10] : MEMORY ALLOC FAILED: VirtualAlloc failed.
[2017-04-18 00:38:10] : Connecting to pool pool.minexmr.com:7777 ...
[2017-04-18 00:38:14] : Connected. Logging in...
[2017-04-18 00:38:14] : SOCKET ERROR - invalid address used for login
  • I misinterpreted that error. I used an exchange address that mined successfully on other pools, I'll try another address and update. – delos Apr 18 '17 at 4:52
  • You might need to talk to minexmr.com on how it would work using exchange address. Maybe it is an integrated address. – Gundamlancer Apr 18 '17 at 6:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.