4

when running monerod I keep getting an error

2017-03-29 20:07:11.704 [P2P9]  ERROR   verify  src/cryptonote_core/blockchain.cpp:3339 Block with id: <db7b9b1d3b1bddfa8dba171afbc2f91346a90f25335c09f00e0ca090b5544056> has incorrect miner transaction

It's now stuck on height 1274863 and can't sync above that. Anyone knows what may be the problem?

  • Which version are you using? – dEBRUYNE Mar 29 '17 at 17:28
  • latest - v0.10.3.1 – Jona Mar 29 '17 at 19:21
  • Same issue as reported here. Make sure to read the full comment chain. In addition, the solution is posted in the comment chain as well. – dEBRUYNE Mar 29 '17 at 22:14
  • 1
    using monero-blockchain-import --pop-blocks 1000 solved my problem. Thanks – Jona Mar 30 '17 at 7:30
  • Jona - can you please write your comment with the fix as an answer to this question, and then accept it? – bigreddmachine Apr 1 '17 at 5:17
2

removing some of the last blocks using

./monero-blockchain-import --pop-blocks 1000

fixed the problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.