1

Newb here

So I've installed and fully synced a GUI wallet on my desktop PC and one on my laptop, it's been 12 hours after sending all my monero from my desktop to my laptop and it still hasn't appeared yet.

Checking the transaction on the GUI reports back: "This address received xx.xx monero, but the transaction is not yet mined"

Putting the Tx ID or the Tx key into xmrchain.net reports that "Nothing in the blockchain has been found that matches the search term :-( Note: there might be 10 block delay between what can be searchable (e.g., key images)"

Any ideas/links to similar problems that have been solved?

1

"This address received xx.xx monero, but the transaction is not yet mined" means that the transaction is seen by the Monero network, but has not been mined yet. Miners select transactions based on the highest fee per byte, to maximize their income. If your transaction has a fee that's a bit on the low side and there is a continuous stream of incoming transactions with a higher (even by a little) fee per byte ratio, those other transactions will be selected and mined first. Your transaction will be mined when there are no more other transactions with a higher fee per byte than yours (or not enough to prevent yours from being included in a block).

Alternatively, your transaction is invalid (for instance, it tries to double spend one or more of its inputs), but that is less likely. If this is the case, the transaction will disappear from the network after 24 hours and the monero will reappear in the sender's wallet (though the double spent inputs are really spent, so the real balance will be smaller as the original was incorrect).

0

Probably your transaction is still pending on your desktop. You can type the following command in monerod.exe then close and open GUI wallet. This should clear all transactions and will show back your monero in your GUI.

flush_txpool
  • Unfortunately this didn't work, my laptop still has 0 balance. – johnsmith77 Mar 30 '17 at 19:00
  • Now the Monero has reappeared back on my desktop machine. Could anyone explain to a noob why this has happened? – johnsmith77 Mar 30 '17 at 21:32
  • 1
    Probably when you run the command flush_txpool deleted all pending transactions it just didn't update your GUI or you failed to run the the flush_txpool but the pending transaction finally expires. Both of this scenario returned your monero back. – Gundamlancer Mar 30 '17 at 23:00
  • I may have tried sending the monero to my laptop whilst one or both wallets were still syncing, would that have caused the transaction to fail? – johnsmith77 Apr 1 '17 at 7:52
0

You should always have your daemon synced before you do anything with the wallet-cli to prohibit this type of confusion. Check the block height and once you confirm both daemons are 100% synchronized you can initiate your transfer and all will be well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.