Over the course of several upgrades, I have been running monerod for many months now, and I have always connected to incoming peers. For the last few months, it was always 8+37.

After running git pull, then backing up my wallet and keys file, then running make clean, and then make, now when I run monerod, my connections are always 8+0. It's been like this for over 24 hours now. Nothing changed with my router, so what might I need to do with my monerod config/settings to start accepting incoming connections?

If it helps to know, I run monerod --rpc-bind-ip my.comp's.homenet.ip --confirm-external-bind (which is the same as I've always run it, though I suppose the --confirm-external-bind wasn't needed before) on Ubuntu 16.04.2 LTS, on version v0.10.2.1-1dfed89.

2 Answers 2


I was suffering from something similar yesterday. When I turned my OS X firewall off, I got the incoming connections back. When I turned it back on, I got 0 incoming connections again.

To fix it, I ended up forcing port 18080 open using this guide. Scroll down to the 10th comment if you need help using Vim (I did). I turned the firewall back on and I got the incoming connections back.

  • I'm not on a Mac, so this doesn't exactly answer my question; but the firewall was the correct place to look. Good stuff. Commented Mar 13, 2017 at 21:48
  • Ah...yes it reads like I was telling you how to open a port on a Mac. I was just putting it in there in case a Mac user had the same problem. However, I think I also have the same problem on my Lubuntu box so I need to apply your answer to that (I think). Cheers Commented Mar 21, 2017 at 12:16

I figured out what my issue was. I checked my ufw rules, and there was no rule for allowing port 18080. After allowing that port and reopening monerod (not sure if that was necessary), I'm quickly up to 7+44.

(@TFI_Charmers, thanks for the push to double check the firewall.)

I don't know why ufw allowed it previously, with no rule, but it must have. Nevertheless, it's good to know that it was not a monero issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.