2

I setup a full node on an Amazon EC2 instance running on Amazon Linux. I can see monerod running testnet in my SSH terminal (fully synchronized).

The security group for this instance has an inbound and outbound rule that allows all connection types, protocols, and ports from any source. I'll change this later but wanted to rule out a firewall issue blocking a port.

On my windows PC I try loading a wallet like so: ./monero-wallet-cli.exe --testnet --daemon-host ec2-xxxxxxx.compute-1.amazonaws.com replacing the xxxxxxx with my actual ec2 link.

I get:

Error: wallet failed to connect to daemon: http://ec2-xxxxxxx.compute-1.amazonaws.com:28081. Daemon either is not started or wrong port was passed. Please make sure daemon is running or restart the wallet with the correct daemon address.

I also tried using --daemon-address with ports 28080 and 28080 with no luck.

Not sure what else I can try to get this working, does anyone have any ideas or suggestions I can try?

1

I was able to solve this issue. Testnet wallets connect on port 28081 by default, so seeing this port being closed made me try a few things. The one that worked, though I'm not sure exactly why, was to set --rpc-bind-ip 0.0.0.0. This opened port 28081 and everything works well now.

  • I have seen others solve the issue that way. I run with --rpc-bind-ip and then the IP address of the node. Of course, I'm running it locally with my local IP address, so maybe that wouldn't work for you. – scoobybejesus Feb 22 '17 at 18:39
  • By default, monerod binds on the loopback interface, so only local processes can reach it. Binding on an external interface (such as 0.0.0.0) means all other machines can reach it (including your own). – user36303 Feb 27 '17 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.