1

I started the Monero Wallet GUI and ticked the Testnet checkbox at the opening page. I imported the testnet wallet from file, that was created in the CLI. After entering the password, I get the following error:

enter image description here

Rahter than clicking on the app from the Applications folder (macOS), I also tried starting the GUI from a Terminal, with the following command: /Applications/monero-wallet-gui.app/Contents/MacOS/monero-wallet-gui --testnet, but after trying to open the wallet, that threw the same error. Any ideas what I'm doing wrong?

1

There's a bug in the gui beta preventing the testnet setting to be saved when opening wallet from file. As a workaround you can create a new testnet wallet and then close and reopen your old one. When you switch back to main net you need to repeat the same procedure: Create a new main net wallet before opening from file.

  • Thanks. I wish I could say I fully understand what that means, but it remains a bit of a puzzle to me which steps are to be performed where (GUI / CLI). When you say "create a new testnet wallet", is that to be done in the GUI itself? – dpzz Jan 31 '17 at 23:05
  • Yes. Was only referring to gui. Instead of choosing open from file you click on create new wallet. You finish the wizard and then close the wallet on settings page and open your testnet wallet. – Jaquee Jan 31 '17 at 23:26
1

At the Welcome page,uncheck the Testnet checkbox,then log in . go to settings and try to connect with default if it worked that's good if not try to change port like dpzz suggest if not check your firewall to make sure nothing blocks the port if so create new roll with the default port or just allow the connection enter image description here

0

As of Beta 2, released on March 29th 2017, the Monero GUI does now properly support testnet.

At the Welcome page, you'd check the Testnet checkbox, and probably change the port number from the default 18081, to 28081 (or 38081), so that the daemon you'll be starting doesn't interfere with a mainnet daemon (if you have that also running):

enter image description here

After opening a testnet wallet, you'll see the extra label Testnet (in red), just underneath the MONERO text in the upper-left corner, e.g.:

enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.