6

I have monerod running on ubuntu linux. After syncing, it continued to upload the blockchain to other users. It is using all of my bandwidth! My VPS has an upload limitation which is rather low (no download limit). I would like to disable this uploading. I tried using out_peers but it gives me an error saying unsuccessful. After googling the error, it was somewhere said that this got fixed.. apparently not. I could also use out_limit but it seems like this is not working properly either (using more bandwidth than I specified). Can I block the ports and have it still download the blockchain? If so, which ports and how can I do this exactly?

7

This post should help you a lot. It discusses how to set bandwidth limits.

You can change them, either when starting monerod:

--limit-rate-up arg (=-1)             set limit-rate-up [kB/s]
--limit-rate-down arg (=-1)           set limit-rate-down [kB/s]
--limit-rate arg (=-1)                set limit-rate [kB/s]

or at runtime (while monerod is already running):

limit                   limit <kB/s> - Set download and upload limit
limit_down              limit <kB/s> - Set download limit
limit_up                limit <kB/s> - Set upload limit

I would suggest setting your upload limit to something slow like 10 KB/s. Setting it to 0 would make it hard (maybe even impossible!) for you to find other peers to download from.

  • 1
    Does this actually work? Testing with v0.11.1.0 on Linux and it doesn't appear to. Setting limit_up to 10 drops download rate to near zero and monerod gets further and further behind the blockchain. Change it back to 2048 and it starts downloading again, but of course will use all upstream bandwidth. – TrentP Jan 3 '18 at 9:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.