4

I am a monero noob, please help. I could not send funds from my MyMonero wallet, so as everyone suggested I imported the keys in the Monero GUI wallet. Problem is, it shows a 0 balance. When I tried sending to this wallet it did in fact increase the balance but my old balance has disappeared.

I tried running a local node, which kept failing and saying "incorrect version" after a few hours, which makes no sense because I downloaded the full package zip. So I tried using a remote node on Moneroworld. When I look at the daemon logs though, it is constantly spamming different IP addresses - "new top block candidate - xxx days behind".

I have no idea what is happening. Can someone offer clarity? I can send and receive now, but my old balance is missing. Am I out of sync or something? I thought remote nodes should be able to pickup my proper balance immediately.

As a side note, when I log back in to view my MyMonero wallet, all the transaction amounts are incredibly weird and wrong.

  • There are several moving parts to be aware of, so I'll handle some of the "low-hanging fruit." A. There is a known issue with the Beta 1 GUI wallet where it will says incorrect version early on in the sync process. B. The daemon logs refer to your daemon. Much of that "spam" is due to having connected to peers who are also syncing. C. A wallet syncs pretty quickly, but not immediately. Unlike bitcoin, your wallet must search for all its outputs everywhere on the blockchain, rather than at a single address. D. Transaction outputs don't always arrive in the denominations you'd expect. – scoobybejesus Jan 19 '17 at 15:37
  • Scoobybejus, do I need to run the daemon when I am connecting to a remote node? I have had monero gui running for days now and It still can't find my original balance. The balance I see in monero gui is what I received after i made the transition. Also on the side note the mymonero wallet is showing some outgoing transactions is incoming positive. – B. D. Jan 19 '17 at 18:22
  • You do not need to run the daemon if using a remote node. Did your daemon fully sync though? Some sync in under an hour. A day or two tops should all but guarantee a full sync. Anyway, this back-and-forth would be better on IRC. Come visit #monero. We need more details. – scoobybejesus Jan 20 '17 at 1:14
2

What probably happened is that you hit a bug which skips early scanning, but skips too much.

If this is indeed the reason, you can fix it by doing this:

  • exit the GUI
  • rename the wallet cache, eg adding ".old" [1]
  • restart the GUI, and wait for the cache to be rebuilt

[1] The wallet cache is one of three files created by the wallet. Assuming you named your wallet "XYZ", then the files would be XYZ.keys (important, back this up and keep it secret), XYZ (that's the cache we're talking about here), and XYZ.address.txt (your public address). So in this example, you'd rename XYZ to XYZ.old. Those wallets are in ~/Monero/Accounts (if you're on Windows, just search the disk for XYZ.keys to find it).

| improve this answer | |
0

enter image description here Hello there i would like to find out if was ever there any plat form called Monero Common Wealth enclosed is the picture as i have funds from my old monero wallet i can see my investments and stil can be able to purchase 60 days packages and i have downloaded the gui wallet successfully and opened a new wallets bit cannot transfere my finds in the old wallet into the new wallet as tge system cannot even withdraw funds since end of September month and i am really very frustrated as i really need money at this point but cannot acces. Kind regards.

| improve this answer | |
  • This does not belong here. I suggest you ask on Reddit, on Bitcointalk, or on Freenode IRC in #monero. The name doesn't ring a bell here fwiw. – user36303 Dec 24 '19 at 1:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.