3

When attempting to run the start-gui.sh in terminal I am receiving:

This application failed to start because it could not find or load the Qt platforms plugin "xcb". Reinstalling the application may fix this problem.

I have already attempted to install the library dependencies via:

apt-get install qt5-default

However I am still receiving the plugin dependency error.

Any help with resolving this would be greatly appreciated.

2

Hi I'm a new monero user here ( I was waiting for the gui) , I've managed to run successfully Monero GUI on Ubuntu 16.04.1 and Lubuntu 16.04.1 from a full installation on an usb stick on a very old laptop (and using an external daemon), hence why I switched to lubuntu which runs much better.

I encountered the problem you describe I did the following to solve it:

sudo apt-get install qml-module-qt-labs-settings qml-module-qt-labs-folderlistmodel

sudo apt-get install qml-module-qtquick-controls qml-module-qtquick-dialogs qml-module-qtquick-xmllistmodel

sudo apt-get install qml-module-qtgraphicaleffects

If you want to speed up even more I tried the following on lubuntu after ditching ubuntu

You'll need

sudo apt-get install libunbound2

and then do:

set QMLSCENE_DEVICE=softwarecontext ./monero-core

set QMLSCENE_DEVICE=softwarecontext ./monero-wallet-gui

and then start

./start-gui.sh

If the above command will not start the GUI try

QMLSCENE_DEVICE=softwarecontext ./monero-wallet-gui

Be aware that I think there is a bug when you create a wallet from a seed it just sometimes does not led pass to the next screen, the right arrow control is not activated but if you start typing on the name of the wallet, the right arrow control activates and then you can click to the next screen with the wallet recreated.

Hope it helps.

|improve this answer|||||
  • 1
    The steps outlined above for the most part helped me, however I was unable to start the GUI by entering "./start-gui.sh" but but had success in starting it with "QMLSCENE_DEVICE=softwarecontext ./monero-wallet-gui" from the start-gui.sh directory. – M0n3r0 M4ni4c Jan 20 '17 at 16:16
0

The answer above is a temporary solution. we are currently working so the Beta runs "out of the box" on those systems.

once the next release is out this issue should be solved.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for?Browse other questions tagged or ask your own question.