1

Before I realized the difference between the 13 word mneumonic seed used by MyMonero.com, and a 25 word seed of a monero-wallet-cli, it was for me too late to obtain my address from MyMonero because they are at the moment offline for maintenance. I understand they do this for adaptations related to the hardfork.

But anyway I got worried. So I tried to bring over Monero's on that online account to a CLI Wallet. Of course it would easier to do so directly with my GUI Monero Wallet, but that seems not possible. You can only do that if you know the full seed containing 25 words. That made me feel quite unhappy.

After a search on Google I found something on a forum that could be the answer for my problem. It was a post placed by FluffyPony as an answer on a problem similar as mine: Just go to https://xmr.llcoins.net/addresstests.html; if you fill in the 13 words Passphrase which you use to get access on MyMonero, then It calculates the public address, the Private Spend Key, the Private view Key, the Public Spend Key and the Public view Key. Then you start up monero-wallet-cli with the command --generate-from-keys [arg]. I did that while hopeful. Then CLI Wallet prompts for the standard address. I suppose that is the same as a Public Address.

After that, it prompts for a Spend Key. Here it starts to be confusing. Which Key is asked here? Is it the Private Spend Key? Or is it the Public Spend Key? After that you get prompted for the View Key. The same confusion on this point. Wich View Key is asked here? The Private View Key, or the Public view Key? This are things most people, such as me,never read about, on almost every place on the internet.Yes?

Ah , okay, lets say on many,I mean really many , many places on the internet. Well , trying to keep this post not so long, I tried all combinations of Spend Keys and View Keys. I have spend almost half a day for controlling my command lines, spelling of all my keys, and outcome of the calculations. To keep it short, nothing worked. And Oh Yeh, Monerod was loaded, and fully Synced.

  • Did you set up a node? Or are you connecting to a remote node? You say none of the options worked, but it's unclear whether you let the wallets try to sync to a node. Did you get the wallets to create (presumably using the private view key and private spend key), and then your monero were not there? If so, then the problem could be that the wallet didn't have a chance to scan the blockchain for the outputs it owns. - Please update your question with some more details. – scoobybejesus Jan 12 '17 at 19:22
  • Yes, The node was loaded in memory, fully synced. – user1077 Jan 12 '17 at 20:33
  • But now I think about it, for security reasons, I did this while Offline. That's because I thought the node was fully synced. i don't mean a remote node. "Did you get the wallets to create (presumably using the private view key and private spend key), and then your monero were not there?" No, the wallet could not be created at all, because both Spend Keys where rejected by Monero-Wallet-CLI. – user1077 Jan 12 '17 at 20:42
  • I tried again, but now internet connected. Problem solved. But now a new question arise. Why this should be done online, while the local node was fully synced? – user1077 Jan 12 '17 at 22:08
  • 2
    If you would like to ask a new question, feel free. But it's definitely a separate question. (Though I'm not sure it's a good question to ask, since it may not be possible to reproduce, since the CLI doesn't need to be online to restore a wallet from seeds, so it was probably a data entry error you had before.) Glad your wallet is working now, though. - Also, please post an answer to your question, so that you may mark it as solved. – scoobybejesus Jan 12 '17 at 22:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.