When I start the daemon from the GUI, it almost immediately turns itself off and I get the following in the log. Can someone translate this into layman's terms? Thanks:

2017-Jan-03 19:25:27.197263 ERROR C:/msys64/DISTRIBUTION-BUILD/src/cryptonote_core/cryptonote_core.cpp:231 Failed to lock C:\ProgramData\bitmonero\.daemon_lock
2017-Jan-03 19:25:27.197263 ERROR C:/msys64/DISTRIBUTION-BUILD/src/cryptonote_core/cryptonote_core.cpp:273 Failed to lock "C:\ProgramData\bitmonero"
2017-Jan-03 19:25:27.197263 Deinitializing rpc server...
2017-Jan-03 19:25:27.197263 Deinitializing p2p...
2017-Jan-03 19:25:27.212263 Deinitializing core...
2017-Jan-03 19:25:27.233265 Failed to deinitialize core...
2017-Jan-03 19:25:27.233265 Stopping cryptonote protocol...
2017-Jan-03 19:25:27.233265 Cryptonote protocol stopped successfully

3 Answers 3


In layman's terms, cryptonote, which is used by monero, is unable to find or create the file .daemon_lock1 and the directory C:\ProgramData\bitmonero2. You can browse to C:\ProgramData to see if the bitmonero directory currently exists.

If it does exist from previously running the CLI version of bitmonero, this problem is likely caused by some lack of permissions where the GUI wallet is not seen as a user that's allowed write access to this folder in the ProgramData directory. From what I understand, only the user who creates the directory has write access3 by default, although I don't fully understand the restrictions set by Windows and monero. I would expect the GUI wallet is supposed have access.

While I don't know exactly where the conflict is, here are a couple of ways you can troubleshoot. Shutdown any monero programs currently running. Check the Windows Task Manager (ctrl + shit + esc) to make sure nothing like monerod.exe is currently running. You can try launching the GUI again and see if it is recognized as a user that has access this time. If it works, then stop here. If not, continue.

If it is still closing with the same error messages, make sure everything monero related is shutdown again. Rename the directory C:\ProgramData\bitmonero to something else like C:\ProgramData\bitmonero-backup. Now launch the GUI wallet which should be able to create this directory itself and you can test whether it launches okay.

Important: If you had previously synced the blockchain and want to restore it, the directory C:\ProgramData\bitmonero\lmdb contains any blockchain data you had previously downloaded and synchronized. Particularly the file data.mdb contains your blockchain data. Shutdown any bitmonero related software first. You should be able to move the old data.mdb from your C:\ProgramData\bitmonero-backup\lmdb directory into the newly created C:\ProgramData\bitmonero\lmdb directory. If the new C:\ProgramData\bitmonero\lmdb contains data.mdb you can delete that before replacing it with your backup data.mdb. Then, delete lock.mdb and run the GUI wallet. It will create a new lock.mdb file.

  • 1
    iyrin: Many thanks. That actually did the trick. For others, as iyrin said, you must use the task manager on Windows to make sure any monero related stuff isn't running undetected in the background. Mine was.. Also, when you replace the lmdb folder don't copy and paste as that will take a long time. Just cut and paste which happens immediately. Jan 4, 2017 at 21:36
  • Why my monero files are forced to stop and looks like block blocks rising Apr 22, 2017 at 4:12
  • ! Cannot execute "C:\ProgramData\bitmonero\monerod.exe" Apr 22, 2017 at 8:00

The problem is Windows 10. I run daemon in compatibility mode Windows 8 and as an administrator


I too had issues with the daemon not starting. As I recall the log files noted port issues and the rings not saving. Problem was solved by manually starting the monerod.exe as an admin and then opening the gui wallet. Seems to be fine now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.