2

Hey guys i bought monero back in the summer and haven't touched it since, my wallet on the monero cli has my stash of monero but i cannot access it because i can't run monerod program on the command line. i get this error RUNNING MAC OS el capitan 10.11.6 and the version before it. (i just updated..)

heres the error i get:

2016-Nov-19 02:38:42.802560 Loading blockchain from folder /Users/won/.bitmonero/lmdb ... 2016-Nov-19 02:38:42.802647 option: fastest 2016-Nov-19 02:38:42.802668 option: async 2016-Nov-19 02:38:42.802684 option: 1000 Segmentation fault: 11

Does anyone know how to trouble shoot this? I just downloaded the latest version and tried running monerod too and same result. The monero cli wallet used to ask me my wallet name which i don't know. I do have my passphrase password so im good i guess. Can anyone give some advice on troubleshooting this?? thanks ahead of time!

  • You should consider writing up a response describing what was wrong and how you fixed it. Then mark that answer as the best answer. It otherwise appears this question is unanswered. – scoobybejesus Dec 29 '16 at 18:32
2

I just noticed that it was in the .bitmonero directory. i just copied and pasted everything there in that directory to be safe and deleted the directory. Then i downloaded the latest zip file from moneros site and ran monerod again and it worked. @barrystyle I guess you were correct thank you!

"There was a hardfork about 2 months ago (hardfork v3); this would be why (more than likely). I'm guessing that your old version has continued past the hardfork blockheight, without it knowing, and you are on an invalid chain." - barrystyle

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.