4

When I startup monerod on my Win7 machine I get the following messages.

2016-Dec-21 13:36:45.919154 Binding on 0.0.0.0:18080
2016-Dec-21 13:36:45.934754 Net service bound to 0.0.0.0:18080
2016-Dec-21 13:36:45.934754 Attempting to add IGD port mapping.
2016-Dec-21 13:36:49.987562 No IGD was found.

I think the no IGD was found might be the cause for not having any IN connections, but I don't know what IGD is. I only have OUT connections and syncing is working.

I configured my router for port forwarding to my desktop on 18080 and running monero v10.0.

3

It means that UPnP is disabled on your router.

What happens if I disable UPnP on my router?

First of all, there is a lot of ambiguity surrounding UPnP. I assume that you mean a device that implements the Internet Gateway Device profile. What happens is that it will not be possible anymore to let applications change firewall settings on the router anymore through UPnP. Some applications will not like it, since they depend on it. Other applications will work, but might not perform as much as before. A good example is Live Messenger. If it can't use UPnP for file transfers it will use a proxy server from Microsoft. Of course this proxy has probably a lot less bandwidth than your own connection.

You can keep it disabled if you've configured port forwarding. When configuring port forwarding, make sure that:

  • External (source) IP is 0.0.0.0
  • Local (destination) IP is the IP of your desktop. You'd want to set up your desktop in such a way to always use the same IP. There are many guides for this easily found.
  • Both external and local ports to be 18080
  • Protocol to be set to TCP
  • The configuration is saved and enabled

If it's set correctly and not working, one reason could be your ISP (as it was in my case). Every ISP has a limited number of IP addresses he can give out, so sometimes you could be sharing an IP with other people. If that's the case, your node will not be seen from the outside.

You can check this. Open your router configuration, and find WAN settings. There, you should see your external IP as reported by your router. Use some web service to check your IP "from the Internet", like this one. If it's different, it likely means that you're behind a double NAT. What you can try to do is call your ISP and tell them you're having trouble configuring port forwarding. They might set you up to have an unique IP, and from that point onward you should be seen from the Internet.

To test if successful, you can scan your port 18080 by using some web service like this one.

  • My router is an older Cisco router that doesn't support UPnP. I'm not clear how to set the external (source) connection to 0.0.0.0 so I'll have to play around with it. From what i can tell, port 18080 is open to the ISP ip (modem ip), and then is forwarded to my local (destination) ip. I have port 8333 open for btc and working but 18080 doesn't seem to want to work even before running monerod. – Mike M Dec 22 '16 at 4:28
  • Check here if you can find detailed instructions for your particular router. Also, monerod must be allowed by Win7 firewall to access the network. Port may be open but it could be that there's 1 more router between your router and the internet. See here under point 2. I'm not sure if bitcoin uses some workaround around this. – JollyMort Dec 22 '16 at 17:24
  • When I changed my router configuration it must have worked even though the whatsMyIp.org/port_scanner link indicated port 18080 was closed, since I'm now getting IN connections. It could be I wasn't caught up yet with the blockchain at the time I was getting no IN connections. Thanks for your help – Mike M Dec 26 '16 at 23:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.