5

I was trying to send some testnet coins to myself to an old address that I posted in a comment in this post. You can see that xmr_eric was successful in sending me some coins at the time. So today I tried to copy the address from that comment I made into monero-wallet-cli and do

transfer 9z1N6pssDU3hvq9X6iqxk2g2e4tfc2WqfiMcKLR2dE8mZVjGN4yCKBD4QE8j‌​xNMMCabNQNzDKLUnZSgu‌​EMMr4YPSBcMuJ8p 1,

but then I get:

Error: wrong address: 9z1N6pssDU3hvq9X6iqxk2g2e4tfc2WqfiMcKLR2dE8mZVjGN4yCKBD4QE8j‌​xNMMCabNQNzDKLUnZSgu‌​EMMr4YPSBcMuJ8p...

I assume it is something that happens when copying from that particular SE comment. I tried from two different computers and the two wallets gave the same error. Actually, if I run exactly the same command, copying the address from inside the wallet itself:

transfer 9z1N6pssDU3hvq9X6iqxk2g2e4tfc2WqfiMcKLR2dE8mZVjGN4yCKBD4QE8j‌​xNMMCabNQNzDKLUnZSgu‌​EMMr4YPSBcMuJ8p 1

I get the normal response:

transfer 9z1N6pssDU3hvq9X6iqxk2g2e4tfc2WqfiMcKLR2dE8mZVjGN4yCKBD4QE8jxNMMCabNQNzDKLUnZSguEMMr4YPSBcMuJ8p 1 The transaction fee is 0.026000000000. Is this okay? (Y/Yes/N/No)n

I compared the two strings in a text editor, and they are visibly identical... And, sure enough, if I just type the address, character by character, then it works fine. Do you know what this could be?

4

In the first two cases you have "\n" in the address.

9z1N6pssDU3hvq9X6iqxk2g2e4tfc2WqfiMcKLR2dE8mZVjGN4yCKBD4QE8j‌<\n>​ xNMMCabNQNzDKLUnZSgu‌​EMMr4YPSBcMuJ8p

  • For some reason, that doesn't show when I copy it to my text editor... but if you can see that, I bet that is the reason. – user141 Feb 16 '17 at 20:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.