12

Let's say you just sent a transaction in monero-wallet-cli and you decide to copy that line and paste it in the daemon for whatever reason. Maybe you are thinking about editing its value or payment ID or something else entirely. If you happen to copy the whole line in the terminal --that is, not stopping at the end of the command-- then as soon as you paste it, the daemon will execute the command (like it normally happens with regular terminal commands outside of the daemon) and a new transaction, with the same parameters, will be submitted to the network, and that will cause you a lot of trouble if not complete loss of those funds, depending on how able you would be to contact the recipient and get him/her to send you your money back...

Maybe I am not considering the whole picture, but IMHO always-confirm-transfers should be set to 1, and not zero by default. (But I am not an expert, so please let me know if I am missing something here!) In any case, to fix that just run the command set always-confirm-transfers 1 in monero-wallet-cli to avoid that kind of problem in the future. Notice, though, that that change is only applied to the particular wallet you were using, not other wallets you might own which would have to be fixed individually.

With that enabled, you will see this prompt next time you are trying to send out a transaction:

The transaction fee is 0.026000000000. Is this okay? (Y/Yes/N/No)

By the way, it would be nice to have another variable require-password to send out transactions, set to 1 by default too.

  • 1
    It was not the default to avoid annoying the user. As dpzz says, this will be changed very soon. – user36303 Oct 10 '16 at 22:29
  • While it's useful information, in the current form it's not suitable for SE, but would fit better to a reddit post. If you could edit it in the form of clearly defined Q&A (you can answer the question yourself, too), we can re-open it. – JollyMort Oct 11 '16 at 1:31
  • @JollyMort: I fixed the title. – user141 Oct 11 '16 at 1:42
  • no biggie, someone flagged it for closing and I'm still getting used to moderating stuff – JollyMort Oct 11 '16 at 1:58
11

I can't tell you why it currently (version 0.10.0.0) is not enabled by default. However, about 10 days ago I filed an issue (#1058) for this on GitHub. Meanwhile, it seems there's a pull request in the works (#1185) to actually enable this by default in the future.

4

This has been fixed by pull request #1225. You can compile from source to benefit now or wait for the next official release.

-    GET_FIELD_FROM_JSON_RETURN_ON_ERROR(json, always_confirm_transfers, int, Int, false, false);

-    m_always_confirm_transfers = field_always_confirm_transfers_found && field_always_confirm_transfers;

+    GET_FIELD_FROM_JSON_RETURN_ON_ERROR(json, always_confirm_transfers, int, Int, false, true);

+    m_always_confirm_transfers = field_always_confirm_transfers;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.