I'm trying to run a node for the first time on linux mint, and let the blockchain update while I was asleep. When I woke up this morning my computer was unresponsive, and I did a hard shutdown.

Now when I start ./bitmonerod, I seem to get an error.

> ~/Desktop/Monero $ ./bitmonerod  Creating the logger system
> 2016-Sep-10 10:01:27.870535 Initializing cryptonote protocol...
> 2016-Sep-10 10:01:27.870570 Cryptonote protocol initialized OK
> 2016-Sep-10 10:01:27.870683 Initializing p2p server... 2016-Sep-10
> 10:01:28.190553 Set limit-up to 2048 kB/s 2016-Sep-10 10:01:28.190686
> Set limit-down to 8192 kB/s 2016-Sep-10 10:01:28.190727 Set limit-up
> to 2048 kB/s 2016-Sep-10 10:01:28.190764 Set limit-down to 8192 kB/s
> 2016-Sep-10 10:01:28.191659 Binding on 2016-Sep-10
> 10:01:28.191734 Net service bound to 2016-Sep-10
> 10:01:28.191749 Attempting to add IGD port mapping. 2016-Sep-10
> 10:01:29.361620 Added IGD port mapping. 2016-Sep-10 10:01:29.361668
> P2p server initialized OK 2016-Sep-10 10:01:29.361754 Initializing
> core rpc server... 2016-Sep-10 10:01:29.361800 Binding on
> 2016-Sep-10 10:01:29.361875 Core rpc server initialized OK on port: 18081 2016-Sep-10 10:01:29.361897 Initializing
> core... 2016-Sep-10 10:01:29.362047 Loading blockchain from folder /home/linuxnoob/.bitmonero/lmdb ... 2016-Sep-10 10:01:29.362070
> option: fastest 2016-Sep-10 10:01:29.362084 option: async 2016-Sep-10
> 10:01:29.362099 option: 1000 2016-Sep-10 10:01:29.362223
> Deinitializing rpc server... 2016-Sep-10 10:01:29.362293
> Deinitializing p2p... 2016-Sep-10 10:01:29.363450 Deinitializing
> core... 2016-Sep-10 10:01:29.363562 Closing IO Service. 2016-Sep-10
> 10:01:29.363597 Failed to deinitialize core... 2016-Sep-10
> 10:01:29.363628 Deinitializing cryptonote_protocol...

What am I doing wrong here?

Thanks for the help!

2 Answers 2


A rough guess would be that the blockchain has been corrupted and may need to be resynced from scratch. The errors aren't really informative enough but it does seem that it shuts itself down after it attempts to verify the blockchain.


Also, maybe you would like to run your node in fast mode, not fastest. I was told that the fastest mode is more prone to corrupt your data base in case of a hard shut down. All you have to do is run bitmonerod with an extra flag:

./bitmonerod --db-sync-mode=fast:async:1000

I am not an expert on that though, so having some confirmation from those of you who are would be great.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.