0

So, I run 2 monerod nodes in a docker container, and one of them is giving the following errors:

2024-01-17 08:14:12.500 [RPC0]  ERROR   net.p2p src/cryptonote_core/blockchain.cpp:2436 Client sent wrong NOTIFY_REQUEST_CHAIN: genesis block mismatch: 
2024-01-17 08:14:12.501 [RPC0]  ERROR   net.p2p src/cryptonote_core/blockchain.cpp:2436 id: <48ca7cd3c8de5b6a4d53d2861fbdaedca141553559f9be9520068053cda8430b>, 
2024-01-17 08:14:12.503 [RPC0]  ERROR   net.p2p src/cryptonote_core/blockchain.cpp:2436 expected: <418015bb9ae982a1975da7d79277c2705727a56894ba0fb246adaabb1f4632e3>,

My monero config file:

# Documentation and examples:
# https://monerodocs.org/interacting/monero-config-file/

regtest=1
keep-fakechain=1  # keep the regtest blockchain, do not remove it after restarting the daemon
no-sync=1
offline=1 # ensures that the node does not connect to the main network and learn of its latest chaintip
fixed-difficulty=1 # keeps the difficulty constant, allowing a large number of blocks to be generated quickly

# Default is 0 = minimal logging; max is 4 - detailed tracing.
log-level=2

p2p-bind-ip=127.0.0.1
#data-dir=/monero/data

# RPC open node
rpc-bind-ip=0.0.0.0
# rpc-bind-port=18551
confirm-external-bind=1
restricted-rpc=0               # Turn off: Restrict RPC to view only commands and do not return privacy sensitive data in RPC calls
no-igd=1                       # Disable UPnP port mapping
hide-my-port=1
rpc-login=monero:monero        # username = monero, password = monero required to connect to API.
disable-rpc-ban=1              # Do not ban hosts on RPC errors.

# Slow but reliable db writes
db-sync-mode=safe

# As recommended at https://docs.monero.study/interacting/monerod-reference:
# Disable ZMQ RPC server. You should use this option to limit attack surface and number of unnecessarily open ports
# (the ZMQ server is unfinished thing and you are unlikely to ever use it).
no-zmq=1

Supervisor configuration file that runs the two monero nodes:

[program:monero-regtest-daemon-0]
# --non-interactive -- Do not require tty in a foreground mode. Helpful when running in a container.
# cannot be specified in config file.
command=monerod --non-interactive --regtest --log-file=/monero/logs/monerod0.log --config-file=/bitmonero.daemon.conf --p2p-bind-port=28080 --add-exclusive-node=127.0.0.1:28081 --rpc-bind-port=18550 --data-dir=/monero/data0
priority=500
autostart=true
autorestart=unexpected
stdout_logfile=/proc/self/fd/1
stdout_logfile_maxbytes=0
stderr_logfile=/proc/self/fd/2
stderr_logfile_maxbytes=0

[program:monero-regtest-daemon-1]
# --non-interactive -- Do not require tty in a foreground mode. Helpful when running in a container.
# cannot be specified in config file.
command=monerod --non-interactive --regtest --log-file=/monero/logs/monerod1.log --config-file=/bitmonero.daemon.conf  --p2p-bind-port=28081 --add-exclusive-node=127.0.0.1:28080 --rpc-bind-port=18551 --data-dir=/monero/data1
priority=501
autostart=true
autorestart=unexpected
stdout_logfile=/proc/self/fd/1
stdout_logfile_maxbytes=0
stderr_logfile=/proc/self/fd/2
stderr_logfile_maxbytes=0

1 Answer 1

0

Resolve conflict: Ensure unique RPC bind ports and consistent data directory paths for Monero regtest nodes to avoid sending incorrect genesis block IDs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.