0

Heeeeeeeeeeyyyyyyyyyyyyyyyyyyyyyyaaaaaaaaaaaaaaaaaaaaaaaaaa guys,

My monero daemon running on linux displays from time to time the message "Incoming connections disabled, enable them for full connectivity". When I use the command "status", the output says I have no incoming connections (nothing weird there) : [...]12(out)+0(in)[...]

Now I do know that my daemon is not obligated to allow incoming connections to work and I do get synchronized with the network without incoming connections. My firewall is allowing the port the daemon uses, I also tried completely disabling the firewall and restarting the daemon but that didn't seem to work either. I would appreciate your help for enabling incoming connections.

The monerod daemon config file (monerod.conf) :

data-dir=/home/crypto/.bitmonero
log-file=/home/crypto/.bitmonero/monero.log

p2p-bind-ip=0.0.0.0
p2p-bind-port=18080


rpc-bind-ip=127.0.0.1
rpc-bind-port=18081

zmq-pub=tcp://127.0.0.1:18084
disable-dns-checkpoints=1
enable-dns-blocklist=1

hide-my-port=1
no-igd=1

The command I used to start the daemon :

monerod --prune-blockchain --config-file=/home/$USER/.bitmonero/monerod.conf

My firewall status (ufw) :

Status: active

Logging: on (low) Default: deny (incoming), allow (outgoing), disabled
(routed) New profiles: skip

 To                         Action      From
--                         ------      ----
18080                      ALLOW IN    Anywhere    
Anywhere on lo             ALLOW IN    Anywhere      
18080 (v6)                 ALLOW IN    Anywhere (v6)     
Anywhere (v6) on lo        ALLOW IN    Anywhere (v6)     

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.