0

My monero node is fully synced. I'm using Ubuntu. In my monero config file I added:

Rpc-bind-ip=127.0.0.1
Rpc-bind-port=18081
Rpc-login=myusername:my password

Then I started monero with ./monerod.

On another terminal I started:

./monero-wallet-rpc --rpc-bind-port 18084 --wallet-file "wallet name " --password "my password" --daemon-address 127.0.0.1 --rpc-bind-ip 127.0.0.1 --rpc-login username: password  

(with password from monero conf)

It gives me errors like

E client has incorrect username/password for server requiring authentication
E throw exception:tools:error: no connection to Daemon

1 Answer 1

0
  1. Rpc-... should be rpc-... (i.e. not capitalized)
  2. ./monero-wallet-rpc ... --password "my password" password here is your wallet password, not the password you have set for the daemon RPC. For that you need to use ./monero-wallet-rpc --daemon-login user:pass.
  3. ./monero-wallet-rpc ...--daemon-address 127.0.0.1 should be --daemon-address 127.0.0.1:18081, or simply --daemon-host 127.0.0.1, or even simpler, remove all settings specifying 127.0.0.1 or 18081 (in both wallet and daemon conf), as they are the defaults for the daemon RPC.

All of the options are documented in:

monerod --help
monero-wallet-rpc --help
2
  • After adding --daemon-login user:pass , it's working now . One more thing... With 127.0.0.1 can I access it from different locations ? Or do I need to change it ?
    – rahi ahmed
    Sep 26, 2023 at 20:17
  • "One more thing... With 127.0.0.1 can I access it from different locations ?" - 127.0.0.1 is localhost only.
    – jtgrassie
    Sep 27, 2023 at 1:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.