1

I’m not an expert on how to manage or use the Monero functions or routines, but something odd happened to me and I can’t wrap my head around why that happened or if this is some sort of bug.

For context, I’m trying to host a Monero node using and old Raspberry Pi running Alpine Linux as the OS. I know that downloading using the monerod daemon is the least efficient way to do it from this system, but it is what I can use at the time. Thus, I’m aware that downloading the blockchain would probably take months because of the hardware limitations (storage space is not an issue though, so the issue does not goes that way).

I ran into a “Segmentation Fault” error when downloading it, mainly out of my naivety by not adding the safe mode flag and relying on the mercy of my internet connection and the local power. I’m well aware that this means that probably the blockchain database got corrupted and the only solution is to download it again. After several tries, I managed to make a robust configuration file so monerod could handle those problems.

Now, the reason why I’m writing this. I ran today again into the dreaded “Segmentation Fault” when running monerod. Just in case I decided to reboot the system and run it again, which this time gave me a lot of strange error messages pointing to an error in the libzmq package. Just out of curiosity, instead of deleting the lmdb file, I decided to try reinstalling the libzmq package and the whole monero bundle just in case and… it now works! No “Segmentation Fault” error! The database is still kicking!

I’ve seen several posts here and elsewhere saying that “Segmentation Fault” is mostly a corruption in the database, but that was not the case in this particular experience! So I’m wondering if it is possible to “survive” this type of errors by checking the Monero dependencies or similar.

1
  • What's the question?
    – jtgrassie
    Aug 18, 2023 at 22:54

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.