1

I am using Moner (Monero 'Fluorine Fermi' (v0.18.1.2-release)) on ubuntu. I am running a regtest with this .conf file and these command line flags:

bitmonero.conf.

# /etc/monero/monerod.conf
#custom
sync-pruned-blocks=1
prune-blockchain=1
enable-dns-blocklist=1
no-zmq=1

# Data directory (blockchain db and indices)
data-dir=/root/monero/.monero  # Remember to create the monero user first

# Log file
log-file=/root/monero/monerod.log
max-log-file-size=0            # Prevent monerod from managing the log files; we want logrotate to take care of that

# P2P full node
p2p-bind-ip=0.0.0.0            # Bind to all interfaces (the default)
p2p-bind-port=18080            # Bind to default port

# RPC open node
rpc-bind-ip=0.0.0.0            # Bind to all interfaces
rpc-bind-port=18081            # Bind on default port
confirm-external-bind=1        # Open node (confirm)
restricted-rpc=1               # Prevent unsafe RPC calls
no-igd=1                       # Disable UPnP port mapping

# Slow but reliable db writes
db-sync-mode=safe

# Emergency checkpoints set by MoneroPulse operators will be enforced to workaround potential consensus bugs
# Check https://monerodocs.org/infrastructure/monero-pulse/ for explanation and trade-offs
enforce-dns-checkpointing=1

out-peers=64              # This will enable much faster sync and tx awareness; the default 8 is suboptimal nowadays
in-peers=1024             # The default is unlimited; we prefer to put a cap on this

limit-rate-up=1048576     # 1048576 kB/s == 1GB/s; a raise from default 2048 kB/s; contribute more to p2p network
limit-rate-down=1048576   # 1048576 kB/s == 1GB/s; a raise from default 8192 kB/s; allow for faster initial sync

Command Line Arguments
/monerod --config-file=./bitmonero.conf --regtest --keep-fakechain --offline --fixed-difficulty 1 --detach

Now; other rpc methods like get_block_count is working and I am getting a valid response. But when I try to run generateblocks, it says Method not found.

Example
Request:

{
    "jsonrpc": "2.0",
    "id": "0",
    "method": "generateblocks",
    "params": {
        "amount_of_blocks": 1,
        "wallet_address": "46brz8wwWzcLh77u8tVjeM4SpdnGRy8xeBXCEiMUgwBkeKBCierr2UPDFMDiL7ieSMGnuqDvkaoXb2x3PW5e9KkT1QdTwKD",
        "starting_nonce": 0
    }
}

Response:

{
    "error": {
        "code": -32601,
        "message": "Method not found"
    },
    "id": "0",
    "jsonrpc": "2.0"
}
0

1 Answer 1

1

generateblocks isn't made available if you are running restricted (which you are, as you have restricted-rpc=1 in your config).

2
  • The generateblocks is now working and the get_block_count is also increasing. But the problem is; I am not getting the coinbase reward on the address i have provided to the generateblocks.
    – Asad Hayat
    Feb 25, 2023 at 22:19
  • "I am not getting the coinbase reward" <- coinbase rewards aren't available (unlocked) until the block is matured (i.e. is >60 blocks deep).
    – jtgrassie
    Feb 25, 2023 at 22:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.