0

Sorry to bother. I'm new to Monero. Recently I followed this article (https://github.com/moneroexamples/private-testnet#step-2-start-first-node) to set up a private chain consist of three nodes. But this is not what I want.

There are three nodes:

node1:172.17.0.2:28080

node2:172.17.0.6:28080

node3:172.17.0.7:28080

problem_1: On node1, when I use option --add-exclusive-node 172.17.0.6:28080, I succeeded and block syncing function was normal. But when I use get_peer_list, nothing returned. It should have returned node2 I guess.

problem_2: I linked node1 and node2, node2 and node3. I think node1 should add node3 to its peer list but it didn't.

problem_3: When I use option --add-peer 172.17.0.6:28080 on node1, nothing happened. I think its function should be the same as --add-exclusive-node 172.17.0.6:28080 except the limitation of peers. And I want to use option --add-peer avoiding the DNS seed influence.

Please let me know if there is any missing information.

I will appreciate it if anyone could solve my problems QAQ. Thanks very much!!!!!

6
  • What are you setting for --p2p-bind-ip on each node?
    – jtgrassie
    Jan 17, 2023 at 2:39
  • Its own ip. To node1 , it is --p2p-bind-ip 172.17.0.2. By the way, I use docker to run these three nodes, so the ip begin with 172. @jtgrassie
    – Harry
    Jan 17, 2023 at 9:33
  • And have you verified each container can reach/ping each other on those IPs?
    – jtgrassie
    Jan 17, 2023 at 14:03
  • Of course. This is the first step QAQ. @jtgrassie
    – Harry
    Jan 17, 2023 at 14:17
  • You should be using --add-exclusive-node not --add-peer as you're attempting to run a private network. With all nodes adding each other as exclusive nodes, mine a block on one and you should see it getting broadcast to the others.
    – jtgrassie
    Jan 17, 2023 at 14:51

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.