I'm currently experimenting with the wallet RPC. I'm using version on stagenet with a remote daemon (tried multiple ones).

When I open (or restore) a wallet, the (what I assume) syncing or scanning gets stuck. The log level is at 4 and I see about 400-430 "process_new_transaction" entries and then it gets stuck.

The RPC server doesn't respond to HTTP requests anymore and also not to SIGTERM.

These are the parameters I use:

--daemon-address http://node.monerodevs.org:38089 --stagenet --rpc-restricted-bind-ip --rpc-bind-port <random_port> --rpc-login <random_user>:<random_pw> --disable-rpc-ban --wallet-dir wallets --log-file rpc.log --log-level 4 --non-interactive --max-concurrency 4

Here's the log: https://hastebin.com/poyopixage.yaml

Hopefully someone can help, I did some research but did not find any solution unfortunately. Thanks for your attention.

  • 1
    The remote node you are trying to connect to, is it your own or simply a node you found online?
    – dEBRUYNE
    Commented Sep 13, 2022 at 5:39
  • its a public one found on monero.fail, however i tried multiple ones
    – Alyx
    Commented Sep 14, 2022 at 9:44
  • 1
    The node may not be up to date. Could you use RINO's node? It is listed on community.rino.io
    – dEBRUYNE
    Commented Sep 18, 2022 at 20:29

1 Answer 1


So, apparently the rpc server stops working when stdout/-err is not read for some time. I dont know if some kind of internal buffer fills up or something.

Reading stdout (and in my case, just discarding it) fixes everything, the rpc server works fine again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.