I am trying to set up a Ledger Nano S as a hardware wallet, and am having issues with the Monero GUI Wallet app ( on macOS ) communicating to the Ledger device. Below are the software versions that I am running ( everything is up-to-date, afaik ). I am not running any third party antivirus software / apps.

Ledger Nano S

Firmware Version: 2.1.0

Bitcoin App Version: 2.0.4

Monero App Version: 1.7.8

Free Memory: 36 KB

Ledger Live Version: 2.41.3

Monero GUI Wallet Version: (Qt 5.12.8)

macOS Version: 11.6.5

No antivirus software installed or running

Ledger Installation Steps:

1.) Ledger Live and Monero GUI Wallet installed on local computer using Homebrew package manager.

2.) Installed Bitcoin app onto Ledger Nano S using Ledger Live.

3.) Installed Monero app onto Ledger Nano S using Ledger Live.

Monero Wallet Generation Steps:

Resource 1: https://support.ledger.com/hc/en-us/articles/360006352934-Monero-XMR-?docs=true

Resource 2: monero-gui-wallet-guide.pdf

1.) Closed Ledger Live.

2.) Opened Monero app on Ledger Nano S.

3.) Opened Monero GUI Wallet.

4.) Mode selection: Simple mode (bootstrap).

5.) Wallet selection: Create a new wallet from hardware

6.) Create new wallet:

Wallet name: username

Wallet location: /Users/username/Monero/wallets

Hardware wallet model: Ledger Nano S

"Create a new wallet from device." selected.

7.) Click Create wallet button.

Result: Receive the following errors "Error writing wallet from hardware device. Check application logs", "failed to generate new wallet: No device found"

Unsuccessful Attempts at Troubleshooting ( re-ran above steps after making the changes listed below ):

1.) Reinstalled Ledger Live and Monero GUI Wallet from website download.

2.) Uninstalled Bitcoin app and account and Monero app, and subsequently reinstalled the Monero app only.

3.) Restarted computer and only started Monero GUI Wallet.

4.) Used different USB cable.

5.) Used different USB port.

6.) Mode selection: Tried Simple mode and Advanced mode.

I don't know where the application logs are located on my filesystem, so haven't checked those yet. I've also tried the Monero wallet generation steps with administrator privileges; no difference. I'm not sure what to try next; any help would be greatly appreciated. Thank you.

  • don't have ledger live open, have the nano x connected and in the Monaro app, after putting passwords in monero gui, look at the screen of the nano x and click to the left for export view key, then accept by pushing both buttons
    – trav34
    Commented Nov 20, 2022 at 4:43
  • If all else fails, see monero.stackexchange.com/questions/9815/….
    – skaht
    Commented Nov 25, 2022 at 2:41


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.