I installed monero gui on Windows a week ago and created my first wallet, unfortunately I ran into an issue with my local node.

FYI, my monerod version is

It does not synchronize all the way to the current node, it's currently lagging 3.8 month behind at node 2504635, and it's been four days.

It looks like there's a pattern visible in the logs:

  • it's starting to synchronize with a remote node:

I [ OUT] Sync data returned a new top block candidate: 2504635 -> 2587587 [Your node is 82952 blocks (3.8 months) behind]

  • then there's an error log with the host a few seconds later:

E [ OUT] Block is invalid or known without known type, dropping connection E Setting timer on a shut down object

  • and then it starts all over again with the next host

I do not know where to start to try and fix this, for now I just cannot use Monero. I have also seen a few of these errors in the log, not part of the main hell loop:

[1648239176] libunbound[26980:0] error: can't bind socket: Permission denied. for

2022-03-25 20:11:09.717 I Target height decreasing from 2587588 to 2412596

I Failed to invoke command 1001 return code -3



W There were 0 blocks in the last 90 minutes, there might be large hash rate changes, or we might be partitioned, cut off from the Monero network or under attack, or your computer's time is off. Or it could be just sheer bad luck.

Remark: i do not wish to use a remote node, I want the blockchain locally for security purposes.

  • I went the route of deleting all node data (96% of the downloaded blockchain to the trash) and starting from scratch. It's been like two days, and it just went above the height I was. Looking good, we'll see.
    – Spikegee
    Commented Mar 30, 2022 at 19:04
  • Shoot, same player shoot again. Around the same height, just a few more blocks, I have the same issue. Is the Monero network under attack or something? Okay I guess I'll try a Linux box. But man that's fustrating.
    – Spikegee
    Commented Mar 30, 2022 at 21:05

1 Answer 1


Final note: it finally worked at the third try, I first imported the available blockchain.raw on getmonero.org, and then the rest of the sync was ok. I will just backup my current bitmonero folder in case this happens again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.