2

My Ledger Nano X is working fine with my Monero wallet. But just as a matter of testing and making sure I can restore the wallet when something bad happens, I followed this guide to recover my wallet from my Ledger: How do I restore / recreate my Ledger Monero wallet?

I did not encounter any issues with that process, but for some reason the restored wallet seems completely empty. So, now I have two wallet files in my GUI on my PC, the restored-wallet is showing ZERO and the other is showing the correct amount.

First I thought I selected the wrong option and created a new wallet, tried a second time and made sure I selected the "Restore a wallet from device" option. With same result.

Both wallets have the exact same wallet-restore-height, primary-address, primary-view-key, primary-spend-key but with a different amount. The network status is "Connected", Daemons and wallet are synced.. I also used the "Rescan wallet balance" option (which is done within a second.?!?), but with no results.

Any idea what I did wrong?

--- EDIT ---

After this post, I did another test on another PC with a complete new Unbuntu install. Installed the GUI and all, went through the recovery guide step by step (with advanced Node). Exact same results: the wallet appears to be empty. So, now I have my old wallet on my laptop showing the correct amount of XMR, a recovered walled on my laptop showing 0, and the same now for my Desktop PC.

I recall that I did select the wrong option on my first attempt to recover the wallet. I had selected "Create a new wallet from device" instead of "Restore a wallet from device". Did that accidentally create some sort of shadow wallet on my Ledger?

Anyway, luckily I still had access to that old wallet on my laptop, so I was able to move the XMR to another software wallet. I then created a new wallet on my Ledger in "Account 1" (instead of the default "Account 0"), transferred the XMR to the new ledger-account-1 wallet, and was able to successfully recover that wallet on my desktop PC.

So, luckily in my case nothing was lost. But if I didn't had access to my old wallet then I would have lost my XMR... I think it might be a bug that once you create a new wallet over your existing one, that you can't access the old anymore...

Anyone with a better idea of what went wrong?

2
  • This also happened to me. Didn't find fixes do far. Did you: Apr 12, 2023 at 14:44
  • Sorry, I haven't. The main thing I learned after this, is that hardware wallet are nice, but I prefer paper wallets now as backup. And on a day-to-day basis run the software wallet in a Virtual-Box located on a VeraCrypt encrypted disk, or use Qubes as OS.
    – Wim
    Apr 14, 2023 at 7:29

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.