0

I downloaded the Monero CLI wallet and the monero-integrations/monerophp library.

After, I ran:

./monero-wallet-rpc --daemon-address 86.181.101.213:18089 \
    --wallet-file testwallet --password 1234 \
    --rpc-bind-ip 127.0.0.1 --rpc-bind-port 18083 --disable-rpc-login

In example.php, I modified like below:

#14 $daemonRPC = new daemonRPC('86.181.101.213', 18089);

#33 $walletRPC = new walletRPC('127.0.0.1', 18083);

#35 $create_wallet = $walletRPC->create_wallet('monero_wallet', 'first');

#36 $open_wallet = $walletRPC->open_wallet('monero_wallet', 'first');

And I reloaded the page. But It is showing:

Fatal error: Uncaught RuntimeException: Unable to connect to https://86.181.101.213:18089/

Error: SSL certificate problem:
self signed certificate in /var/www/html/monerophp-master/src/jsonRPCClient.php:140

Stack trace: 
#0 /var/www/html/monerophp-master/src/jsonRPCClient.php(80): MoneroIntegrations\MoneroPhp\jsonRPCClient->getResponse() 
#1 /var/www/html/monerophp-master/src/daemonRPC.php(112): MoneroIntegrations\MoneroPhp\jsonRPCClient->_run() 
#2 /var/www/html/monerophp-master/src/daemonRPC.php(129): MoneroIntegrations\MoneroPhp\daemonRPC->_run() 
#3 /var/www/html/monerophp-master/example.php(16): MoneroIntegrations\MoneroPhp\daemonRPC->getblockcount() 
#4 {main} thrown in /var/www/html/monerophp-master/src/jsonRPCClient.php on line 140

What could be wrong?

4
  • 1
    See the (currently open) issue #125. You can always disable SSL by passing false in the daemonRPC constructor.
    – jtgrassie
    Oct 1 at 5:13
  • Also, I cannot even reach the daemon you have specified (86.181.101.213). Make sure that is accurate and reachable / online.
    – jtgrassie
    Oct 1 at 20:10
  • I tried other active nodes from here. But it is still not working with same message.
    – kellophoo
    Oct 2 at 6:57
  • See the (currently open) issue #125.
    – jtgrassie
    Oct 2 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.