0

Right now I am using github.com/PsychicCat/monero-nodejs and am getting the following error:

Error: connect ECONNREFUSED 127.0.0.1:18082 at TCPConnectWrap.afterConnect [as oncomplete (node:net:1138:16) {
   errno: -111,
   code: 'ECONNREFUSED',
   syscall: 'connect',
   address: '127.0.0.1',
   port: 18082
}

Anyone please help?

1 Answer 1

1

You have to connect to the host and port you are using for monero-wallet-rpc. Port 18082 is the default monerod zmq port, so if you want to use that port for the wallet RPC, you have to either disable zmq in monerod or tell monerod to use a different zmq port.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.