1

I seem to be running the latest version of the GUI screenshot attached. The blockchain looks to me like it's synchronized correctly.

GUI Status

In the logs for my blockchain I see that it is synced :

2021-07-22 03:27:15.775 [P2P0]  INFO    global  src/cryptonote_protocol/cryptonote_protocol_handler.inl:413 SYNCHRONIZATION started
2021-07-22 03:27:19.484 [P2P5]  INFO    global  src/cryptonote_protocol/cryptonote_protocol_handler.inl:1680    Synced 2410071/2410071
2021-07-22 03:27:19.484 [P2P5]  INFO    global  src/cryptonote_protocol/cryptonote_protocol_handler.inl:2424    SYNCHRONIZED OK
2021-07-22 03:27:19.485 [P2P5]  INFO    global  src/cryptonote_protocol/cryptonote_protocol_handler.inl:2464    
2021-07-22 03:27:19.485 [P2P5]  INFO    global  src/cryptonote_protocol/cryptonote_protocol_handler.inl:2464    **********************************************************************
2021-07-22 03:27:19.485 [P2P5]  INFO    global  src/cryptonote_protocol/cryptonote_protocol_handler.inl:2464    You are now synchronized with the network. You may now start monero-wallet-cli.
2021-07-22 03:27:19.485 [P2P5]  INFO    global  src/cryptonote_protocol/cryptonote_protocol_handler.inl:2464    
2021-07-22 03:27:19.485 [P2P5]  INFO    global  src/cryptonote_protocol/cryptonote_protocol_handler.inl:2464    Use the "help" command to see the list of available commands.
2021-07-22 03:27:19.486 [P2P5]  INFO    global  src/cryptonote_protocol/cryptonote_protocol_handler.inl:2464    **********************************************************************

I am having difficulty getting the GUI to work, the gui gets stuck.

  • It is allways stuck on either Synchronizing or Connected state in the bottom left.
  • i.e clicking the Account tab causes the application to hang and stop responding in windows.
  • Closing the GUI never actually closes and indefinitely hangs in closing wallet state.

Examining the logs of the GUI did not help me either I see no errors.

I am using a Ledger Nano S if that matters...

I'm not sure what to do the blockchain(daemon) looks like it's all synced up, the GUI is in the latest version. Any suggestions would be very helpful as I am new to this.

*Edit. I re-downloaded the GUI installer (windows msi x64) last night. I've ran it hoping that it will reinstall the GUI and not touch the blockchain bit. It seems to have done just that but I'm still stuck, that is daemon gets synced up, but the wallet blocks do not.

As per a different post suggesting on how to get unstuck: I deleted the file p2pstate.bin. And changed the Daemon startup flags to --block-sync-size 10.

Next Day

I started up again today. There were 151 blocks to sync. The daemon log states it is fully synchronized, yet the GUI is stuck on "Blocks remaining 1". It looks to be permanently stuck yet again. Thanks for reading ;)

3
  • Are you exporting your Ledger view key on wallet opening? – selsta Jul 22 at 17:03
  • No I am selecting not to export the key. I wanted to keep it secret. – mac671 Jul 22 at 17:09
  • Thank you! I've marked your answer. After I've selected to export the view key my wallet blocks have synchronized. – mac671 Jul 22 at 17:45
2

The Ledger hardware wallet isn't strong enough to scan blocks on device, you have to export your view key on wallet opening. Not doing this has these weird side effects you are describing in your issue.

If you are exporting your view key then malware could read out the view key out of RAM and see incoming transactions into your wallet. Similarly malware could screenshot your desktop and see incoming transactions and balance even if you don't export the view key.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.