1

Hi complete noob here but still want to run a monero node:

I completed the Qubes Whonix Isolation guide for a monero node.

I created a wallet in wallet-ws then. Shutdown. Then I opened monerod-ws and ran: monerod --log-level 4 in terminal and got some errors:

T BlockchainLMDB::open
W Failed to check for Nmap support: write failed: No space left on device
E Error opening database: Failed to check for map support: write failed: No space left on device.
E Exception in main! Failed to initialize core.

Before this however I used to get the Failed to bind IPv4 to 0.0.0.0 etc error. But this time I ran monerod and got this new error somehow it changed smh.

In the qubes manager section I set the Private storage max to 95000MiB The System storage is at 10240 MiB and gray out so I can't change that.

But I also remember I had my qubes to dynamically increase in size as I use them so Idk why it's saying now that disk is full but yesterday it was a different error. How do I increase the size of the device?

And where can I find list of commands to troubleshoot daemon.

Like: How to know if daemon is sync blocks and how many. How to know if daemon is connected to tor. Am I supposed to change the ip of the daemon to my own ip as in the ip of the monerod-ws vm?

I tried the --help section but I am super noob.

2

Unless you are running monerod in prunning mode, you'll need more than "95000MiB".

Storage seems full. You can check with df -h inside daemon workstation.

By default, Qubes workstations can't communicate between them. You can check this resource for one possible configuration

2
  • Question I set private storage max size to 13448 MiB,(120gb) more than enough. However, when I run df -h in the terminal I get: Size Used. Avail. Dev/xvdb 13GB. 13GB. 0 Why does this block have a limit when I set the max limit to 120GB. (My system storage max size is 10240MiB.) My qube is on the dynamically change size if that even matters.
    – Facelook
    Jul 18 '21 at 1:57
  • 1
    it should increase as needed. 13 000 MiB is about 13 GB not 120 Jul 18 '21 at 2:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.