0

I'm certain the forwarded port of 18081, 18089, 18080 are forwarded to the machine and i've completely disabled windows firewall. Is this my ISP blocking this port?

C:\Users\monero-gui-v0.17.2.1>monerod.exe --public-node --restricted-rpc
2021-05-02 22:26:03.387 I Monero 'Oxygen Orion' (v0.17.2.0-release)
2021-05-02 22:26:03.389 W --public-node is enabled, but RPC server 127.0.0.1:18081 may be unreachable from outside, please check RPC server bind address
2021-05-02 22:26:03.390 I Initializing cryptonote protocol...
2021-05-02 22:26:03.391 I Cryptonote protocol initialized OK
2021-05-02 22:26:03.393 I Initializing core...
2021-05-02 22:26:03.395 I Loading blockchain from folder C:\ProgramData\bitmonero\lmdb ...
2021-05-02 22:26:03.560 I Loading checkpoints
2021-05-02 22:26:03.561 I Core initialized OK
2021-05-02 22:26:03.562 I Initializing p2p server...
2021-05-02 22:26:03.579 I p2p server initialized OK
2021-05-02 22:26:03.579 I Initializing core RPC server...
2021-05-02 22:26:03.580 I Binding on 127.0.0.1 (IPv4):18081
2021-05-02 22:26:05.781 I core RPC server initialized OK on port: 18081
2021-05-02 22:26:05.791 I Starting core RPC server...
2021-05-02 22:26:05.792 I core RPC server started ok
2021-05-02 22:26:05.793 I Public RPC port 18081 will be advertised to other peers over P2P
2021-05-02 22:26:05.794 I Starting p2p net loop...
1
  • In future, please use the formatting buttons in the editor. Otherwise things like this log output are unreadable. – jtgrassie May 3 at 0:14
0

If you read your logs:

W --public-node is enabled, but RPC server 127.0.0.1:18081 may be unreachable from outside, please check RPC server bind address

Then check the monerod --help output:

--rpc-bind-ip arg (=127.0.0.1)             Specify IP to bind RPC server
--rpc-restricted-bind-ip arg (=127.0.0.1)  Specify IP to bind restricted RPC server
--confirm-external-bind                    Confirm rpc-bind-ip value is NOT a loopback (local) IP

So to bind all interfaces (which includes external), use 0.0.0.0 instead of 127.0.0.1, and use --confirm-external-bind to state you know what you're doing.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.