1

Title says it all. It's a basic passphrase that I always use (bad practice, I know). The Model T was set up using Shamir shares. Shares are all valid, according to the Trezor. Monero wallet password works fine, but the passphrase gives a different wallet address than the one originally created in the wallet/.keys file.

What's odd is that the second or third time I logged into the wallet, the same passphrase was not accepted when typed on Computer, only when typed on hardware device. And now sure enough, a couple weeks later, it's not being accepted at all. Based on this I am assuming that there is some weird glitch going on and this is not simply forgetting a passphrase.

If it's relevant: I don't recall exactly, but I believe I updated the Trezor firmware after realizing the passphrase wasn't going to work no matter how many times I tried. Also, I am unsure if I added the official Trezor passphrase before or after setting up the Monero wallet. In any case it is the same passphrase and even when I disable it on Trezor suite, the monero wallet is still inaccessible. I have also tried accessing the wallet via CLI, to no avail.

Is there a way to go about recovering the XMR wallet with Shamir shares? I found this--I can make it as far as converting the Shamir shares to a bip39 seed/bip32 root key, but from there..?

1
  • I am also having this issue, same setup with Shamir shares. Wrote down everything that the Trezor would allow me to; passphrase, wallet restore height, primary address, secret view key, public view key, and public spend key. The private spend key and the seed were obscured by the Trezor T. When trying to link these addresses to the wallet, I receive an error "couldn't open wallet: device wallet does not match wallet address..." Then lists the address wallets. This is beyond me, I've had problems with Monero with another wallet because I lost the seed. I've scoured the forums and found a few ca Jul 1 at 5:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.