1

New to setting up my own Monero node. Hoping to join the faithful :)

I have QNAP NAS which I currently have a successful Docker Bitcoin node running on. I am looking to do the same with Monero. The QNAP NAS has a Container Management Tool built in called ContainerStation. I have used the Docker image here https://hub.docker.com/r/kannix/monero-full-node posted by Kannix. Everything installs and starts up fine, it is set to run on ports 18080 and 18081 which I believe are standard from my reading. The blockchain is syncing fine but I when I run the status command I show zero connections... even though I am obviously connected to something, otherwise I couldn't be getting synchronized, at least that's my understanding. The results of the status command are below:

$ ./monerod status                                                                                                                                              
2021-02-21 06:29:29.865 I Monero 'Oxygen Orion' (v0.17.1.9-release)                                                                                             
Error: Problem fetching info-- rpc_request:                                                                                                                     
Height: 1328116/2301498 (57.7%) on mainnet, mining info unavailable, net hash 76.54 MH/s, v5, 0(out)+0(in) connections  

I have created the necessary port forwarding rules on my firewall. I have checked that the ports are forwarding correctly with https://www.yougetsignal.com/tools/open-ports/. Both 18080 and 18081 show as open.

As I mentioned at the beginning of the post, I have a Docker Bitcoin node running successfully with a very similar setup, I used the Docker image here https://hub.docker.com/r/kylemanna/bitcoind posted by Kylemanna. I haven't had any issues with the Bitcoin node, connections are good. Hoping someone can point me in the right direction, I would like to participate in helping make the dream work :) Any thoughts on what could be causing the lack of connections reported when running this status command?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.