0

First of all restoring my wallet is not an issue, no inocent XMR's are being harmed here.

My issue my pc crashed with my wallet open I am using monero-gui latest version on Ubuntu.

While starting the monero-gui after a reboot the monero-wallet-gui does not want to open the wallet anymore

ERROR   frontend    src/wallet/api/wallet.cpp:416   Error opening wallet with password:  internal error: "/path/to/monero-storage/redacted/redacted.keys" is opened by another wallet program

Being curious to which program/user was having this keys file open I tried to do some research.

But fuser came up empty

fuser /path/to/monero-storage/redacted/redacted.keys 

lsof at least found some traces monero-wallet-gui but the specific keys file was not opened

lsof | grep monero

I killed the process anyways but still the same error when trying to restart the wallet.(later I realized this where just leftovers from me starting the wallet gui before)

Then I moved on lookup for some hidden lock files but ls -la did not reveal anything in the monero-storage folder this revealed nothing.

So I gave up searching my self as this is all the linux knowledge I have to investigate.

But still curious to why this is happening I was wondering if someone where knows this error and what causes it?

3
  • sudo lslocks shows which commands locked which files and sudo flock -u <file> can remove a file lock. – jtgrassie Jan 31 at 22:46
  • @jtgrassie thanks for you replay. It help motivate me search further in the end i found that it was as simple as file ownership. I started the monero-wallet-gui from the command line using sudo so the keys file was owned by root – Mazaka Jan 31 at 23:48
  • Please add an answer with your solution. – user36303 Feb 7 at 1:48
1

In the end it turned out the the keys file owner was root setting this to the correct owner with chown solved the problem.

sudo chown $USER:$USER keys /pathto/monero-gui/monero-storage/$USER/$USER.keys
sudo chown $USER:$USER keys /pathto/monero-gui/monero-storage/$USER/$USER

It was caused by me using sudo the first time I run the wallet this created the wallets keys file with root as owner.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.