0

I found that my Monero GUI wallet keeps crashing during the initial blockchain synchronization, and when I start off from where it crashed, data.mdb in C:\ProgramData\bitmonero\lmdb has been corrupted (the Error opening database: Failed to query m_blocks: MDB_BAD_TXN: Transaction must abort, has a child, or is invalid response in the command prompt). Typically, it gets 2.0 to 3.0 GB in size, though sometimes as much as 6.0 GB.

To work around this, I've been running monerod.exe in the Windows 10 command prompt and adding flags such as these in order to keep the synchronization from using too much CPU power or bandwidth:

--max-concurrency 1 --block-sync-size 10 --out-peers 5 --limit-rate 500

Unfortunately, none of these have been successful regardless of the numerical values in the flags. Do I need to install the wallet on another computer, or could I try another workaround?

EDIT: After updating to the latest version and reducing out-peers to 3, I'm having more success. The daemon didn't so much crash as freeze the computer and corrupt the databases. Two crashes without corruptions later, and I have over 70% of the database saved. The remainder will take several more days.

2
  • i hope you get an answer fast because this has been a problem for me for the last like 3 f***ing weeks its a nightmare and now my blockchain will take forever to sync (i run a local node). ive never had this problem before. for the record im running the GUI 17.1.8 on windows 10. i cant find anything about this problem anywhere but m getting this error and the crashing as well – shay Jan 16 at 10:50
  • @shay - See: monero.stackexchange.com/a/12643/44 – dEBRUYNE Jan 24 at 14:31
2

Monero prior to 0.17.1.9 had a DoS vector where someone could send monerod a massive ~100 MB packet, crafted such that parsing it would take lots of memory (on the order to 30 GB I think, I might be off). I assume this is what you both got, and the OS killed the process due to no RAM available, rather than an actual crash. Update to 0.17.1.9 and if it still happens, then it's another problem which should be reported to https://github.com/monero-project/monero.

0

Reducing --out-peers to 3 and running the process on and off for a month in total eventually solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.