1

I'm using the following guide in order to setup a Monero node on my computer:

Monero Node Guide

I am on step 4 and when I run sudo journalctl -fu monerod.service I get the following log:

monerod.service: Can't open PID file /home/andy/.bitmonero/monerod.pid (yet?) after start: Operation not permitted

Here is the source code for my monerod.service file:

[Unit]
Description=Monero Full Node
After=network.target

[Service]
User=monero
Group=monero

Type=forking
PIDFile=/home/andy/.bitmonero/monerod.pid

ExecStart=/usr/local/bin/monerod --restricted-rpc --block-sync-size 50 --confirm-external-bind --config-file /home/andy>

[Install]
WantedBy=multi-user.target

When I run monerod --config-file /home/andy/.bitmonero/monerod.conf status I get the following error:

Error: Couldn't connect to daemon: 127.0.0.1:18081

I'm not sure how to fix either of these issues, does anybody know how I am supposed to move forward from here? I am so lost!

2
  • 1) --config-file /home/andy> is missing the rest of the path 2) there is no --detach 3) please post the content of your monerod config file in the question 4) have you created the monero user and group specified in your service? 5) does the monero user have write access to the /home/andy/.bitmonero directory? – jtgrassie Dec 16 '20 at 15:36
  • The blog post you follow is outdated and buggy. I'd recommend to get binaries from getmonero.org/it/downloads and follow their instructions. – Yuri Ginsburg Dec 21 '20 at 5:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.