0

I'm new to this, so please bear with me. I'm using GUI 0.17.1.4 to run a single wallet on a Mac.

I made a transfer from my exchange to my wallet. The transfer didn't arrive, so I went to getmonero.org to look for help and saw that I needed to upgrade to 0.17.

I updated and the transfer arrived successfully. At that point, my antivirus software quarantined a file related to Monero. I didn't make a note of the file's full name, but it included "MacOS:Milner" or similar. I restored the quarantined file from antivirus and all appeared fine.

However, after closing the wallet and reopening it later, the daemon wouldn't start. Searching for a solution took me to this solution. I followed the instructions described there, which involved resyncing from scratch.

The daemon now starts, but the balance and most recent transactions are from before I upgraded to 0.17. The most recent transfer has gone. What's the best way for me to recover please?

5
  • Has your resync already completed? If not, that is probably the reason your previous transactions are not displayed.
    – dEBRUYNE
    Commented Nov 20, 2020 at 20:08
  • Thanks for responding @dEBRUYNE. Yes, I think this is after the resync has completed. The log read "2020-11-20 07:02:30.146 I You are now synchronized with the network. You may now start monero-wallet-cli."
    – 2pops
    Commented Nov 21, 2020 at 10:39
  • I don't know if it's relevant, but I've been getting loads of "[51.91.108.125:18080 OUT] peer claims higher version that we think (14 for 2234504 instead of 12) - we may be forked from the network and a software upgrade may be needed" throughout the resync process, and continued to after the "You are now synchronized with the network".
    – 2pops
    Commented Nov 21, 2020 at 10:41
  • @dEBRUYNE: I think I've solved the problem. I had inadvertently opened v0.15 of the GUI, which was still on my system without me realising it. Have now opened 0.17, which is currently showing my old balance, but is syncing. Pretty confident it will sync and update with the new transfer.
    – 2pops
    Commented Nov 21, 2020 at 11:07
  • All right. Please let me know if the balance is displayed properly after the sync has completed.
    – dEBRUYNE
    Commented Nov 21, 2020 at 17:15

1 Answer 1

0

This problem was caused by me not understanding how the GUI update process works. I didn't realise I had both the old and new versions on my system, and was inadvertently opening the old version. My balance is now accessible as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.