1

I'm running monerod --rpc-bind-port 18081 --restricted-rpc, and want other people to be able to sync off my nodes. If I port-forward on my router, which ports should I open?

Edit: According to https://canyouseeme.org/, I already have port 18080 open. It seems monerod created this automatically. Am I already good to go?

2

As I answered to your previous question, you do not need to forward any ports for the p2p interface. This is the interface nodes use to send each other data, such as blocks. transactions and peerlists. Other nodes can sync with you fine without router port forwarding because when you initiate an outbound connection to a peer, it is kept open, thus data can be both sent and received. More important for p2p traffic is how many connected peers you allow and how much bandwidth you allow. Settings already explained.

Wallets however need to talk to nodes over the RPC interface. Thus, if you want to help wallet users who don't run their own node, you can forward the RPC port to your RPC listening port (in your example this is port 18081). This you do on your router, normally under a section named "port mapping" or similar. You will be filling in details to tell your router to "make requests coming to port 18081 go to computer your.local.ip port 18081"

| improve this answer | |
  • Do I have to start the RPC as well to do this? Using canyouseeme.org, 18081 is showing as offline, even though it's forwarded. – Dr-Bracket Nov 15 '19 at 23:46
  • RPC is started by default. When you start the daemon, you will get a line like core RPC server initialized OK on port: 18081 as one of the log messages. – jtgrassie Nov 16 '19 at 1:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.