3

While using monero-wallet-cli, I am frequently getting this message:

 ____________________________________________   
/ I locked your Monero wallet to protect you \
\ while you were away                        /
 --------------------------------------------
        \   (__)
         \  (oo)\_______
            (__)\       )\/\
                ||----w |
                ||     ||


Locked due to inactivity. The wallet password is required to unlock the console.

How can I disable this behavior or increase the timeout?

1 Answer 1

3

By default, the wallet will ask for the password after 90 seconds of inactivity. You can see this by loading the wallet, then running this command:

set

Look for the entry for inactivity-lock-timeout.

You can increase the timeout to say 10 minutes like so:

set inactivity-lock-timeout 600

Or disable this functionality like so:

set inactivity-lock-timeout 0
3
  • Maybe in combination with set ask-password never not sure if that one is necessary thou :) I had some problems with this, while running in screen. Commented Nov 12, 2019 at 18:03
  • @MogensTrasherDK Depends on your desired result. I want to be prompted when spending, but not for idle timeouts. Commented Nov 13, 2019 at 21:20
  • Tried to use set inactivity-lock-timeout 0 in my .sh file to start monero cli, but no luck, it is still asking about password after very short time of idling. set inactivity-lock-timeout 0 ./monero-wallet-cli --config-file monero.config What's wrong with my script file or with monero.config?
    – user216652
    Commented Nov 2, 2022 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.