0

I started with a new machine.

I got the latest version - https://downloads.getmonero.org/cli/monero-linux-x64-v0.14.1.0.tar.bz2

Put this in /mnt/monero/.monero.

Copied the binaries to /usr/local/bin.

Created the config file and the service:

Config

data-dir=/mnt/monero/.monero  
log-file=/mnt/monero/monerod.log  
max-log-file-size=0  
p2p-bind-ip=0.0.0.0  
p2p-bind-port=18080  
rpc-bind-ip=0.0.0.0  
rpc-bind-port=18081  
rpc-login=xxx:xxx  
#confirm-external-bind=1  
restricted-rpc=1  
no-igd=1  
db-sync-mode=safe  
enforce-dns-checkpointing=1  
out-peers=64  
in-peers=1024  
limit-rate-up=1048576  
limit-rate-down=1048576  

Service

[Unit]  
Description=Monero Full Node  
After=network.target  

[Service]  
User=xxx  
Group=xxx  

Type=forking  
PIDFile=/mnt/monero/monerod.pid  

ExecStart=/usr/local/bin/monerod --config-file /home/xxx/.bitmonero/monerod.conf --detach  

[Install]  
WantedBy=multi-user.target 

Then started the service:

sudo service monerod start

And I get:

● monerod.service - Monero Full Node
   Loaded: loaded (/lib/systemd/system/monerod.service; disabled; vendor preset: enabled)  
   Active: failed (Result: timeout) since Tue 2019-10-29 08:16:41 UTC; 9s ago  
  Process: 4819 ExecStart=/usr/local/bin/monerod --config-file  
 /home/graeme/.bitmonero/monerod.conf --detach (code=exited, status=0/SUCCESS)  

Oct 29 08:15:11 systemd[1]: Starting Monero Full Node...  
Oct 29 08:15:12 monerod[4819]: 2019-10-29 08:15:12.902        I Monero 'Boron Butterfly' (v0.14.1.0-release)  
Oct 29 08:15:12 monerod[4819]: Forking to background...  
Oct 29 08:15:12 systemd[1]: monerod.service: Can't open PID file /mnt/monero/monerod.pid (yet?) after start: No such file or directory  
Oct 29 08:16:41 systemd[1]: monerod.service: Start operation timed out. Terminating.  
Oct 29 08:16:41 systemd[1]: monerod.service: Failed with result 'timeout'.  
Oct 29 08:16:41 systemd[1]: Failed to start Monero Full Node.  

So nothing funny, simply following the documentation.

I'd like to run a node and help.

  • Try to run monerod –config-file /home/xxx/.bitmonero/monerod.conf and see if it complains about something. If you want monerod to run in the background, you must add --detach to your launch command. – Mogens TrasherDK Oct 27 at 16:02
  • I think it might be resource related. I ran a big server, with 4 chains, each in an attached volume. I am splitting this up now, and building 4 instances. Getting BTC and BCH up from the repos was quick, but I am running into issues compiling LTC and XMR, in terms of the instance resources. Maybe I missed something when I compiled Monero on the single box. – Graeme Oct 27 at 18:24
  • Getting further, Active: activating (start) since Sun 2019-10-27 19:05:41 UTC; 1min 23s ago, But on the 3rd status request : Active: failed (Result: timeout) since Sun 2019-10-27 19:07:15 UTC; 27s ago .. and it keeps complaining about the PID : /mnt/monero/monerod.pid (yet?) after start: No such file or directory It should create the process ID ? – Graeme Oct 27 at 19:08
  • Actually, running a service for monerod is not working, it might be that the daemon is not happy with the config file format. But simply running monerod with your option is fine. So I just created a cron job for @reboot, and @hourly. Simple like that. – Graeme Oct 29 at 9:07
  • Your service file is still wrong. – jtgrassie Oct 31 at 16:25
2

walletnotify=/mnt/monero/notifysitestx.sh %s blocknotify=/mnt/monero/notifysitesblock.sh %s

There are no options walletnotify or blocknotify, you probably want block-notify.

See monerod --help for all the available options and syntax.

Running the daemon with the --config flag I get...

There is no option called --config, it's --config-file.

PIDFile=/run/monero/monerod.pid

Have you created the directory /run/monero/ though?

–pidfile /run/monero/monerod.pid

The parameter is wrong. It should be --pidfile /run/monero/monerod.pid. Note the double hyphen --. You make this same mistake with other parameters also.

I am not binding p2p for now, only RPC

p2p automatically binds.

Compiling Monero alone on a box, I had to up it to 8GB of RAM.

Monero can be compiled on a Raspberry Pi, so if you needed to increase your RAM to 8GB, you must have been seriously exhausting the RAM on other things.

UPDATE

After you rewriting your question, you now specify PIDFile=... in the service file, but you removed the parameter --pidfile .... So you're telling systemd there will be a PID file, but don't tell monerod where to create it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.