1

I am running the latest version of monerod and monero-wallet-rpc on my Ubuntu 16 machine. My monerod daemon is fully synced and seems to be working fine. I am using monero-wallet-rpc to run a faucet service for Monero and require my users to be able to withdraw from their wallets.

When I run the wallet RPC, I am getting a large amount of warnings and error messages.

E Failed to parse transaction from blob

W Failed to parse transaction from daemon

E Invalid tx data

Here is my RPC command:

./monero-wallet-rpc --rpc-bind-port 28083 --wallet-file monerowallet --password THISISWHERETHEPASSWORDIS --disable-rpc-login

And how I run monerod

./monerod

What could be the cause of these errors?

  • Can you also paste your daemon command line please? – jtgrassie Aug 15 '19 at 4:19
  • I have updated my question – Barney Chambers Aug 15 '19 at 4:37
  • Looks like you are on an incorrect chain. You definitely running the latest version and definitely fully synced? You can check your daemons height (status command) against xmrchain.net. – jtgrassie Aug 15 '19 at 4:58
  • The height is correct, I'm definitely on the right chain – Barney Chambers Aug 15 '19 at 5:02
  • @Barney can you specify when you get those errors please? – jtgrassie Aug 16 '19 at 11:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.