0

I have a few transactions that are stuck in the pending status (for about 2 days now). My unlocked balance is near 0, so I cannot transfer any XMR. How can I solve these stuck transactions? What is the reason?

0

How can I solve these stuck transactions?

If you have a transaction stuck at the daemon, you can flush it with flush_txpool:

$ monerod help flush_txpool
Command usage: 
  flush_txpool [<txid>]

Command description: 
  Flush a transaction from the tx pool by its <txid>, or the whole tx pool.

Then in your wallet you can rescan_spent.

What is the reason?

If your domain is not in sync with the rest of the network or is on an incorrect chain, this kind of thing can happen.

| improve this answer | |
  • flush_txpool "Pool successfully flushed" rescan_spent show_transfers and still transaction is pending, new one transaction, older are failed. Can I be sure that this pending transaction will not be sent twice if I reply? – gdfhsd33 Mar 28 '19 at 15:59
  • And still no ulocked Monero in wallet. – gdfhsd33 Mar 28 '19 at 16:08
  • Can you see any of your pending txs by searching on xmrchain.net ? – jtgrassie Mar 28 '19 at 17:06
  • I've made flush again, closed daemon, run again and all transactions are failed, seems problem solved. – gdfhsd33 Mar 29 '19 at 6:51
  • Going to mark this as solved then @gdfhsd33 – dEBRUYNE Mar 29 '19 at 17:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.