1

I am using v0.14.0.2-release on Windows, and launching the monerod daemon with ./monerod.exe --block-sync-size=10 --data-dir=/f/.monero/ syncs correctly up to height 1788144. After that, the daemon stops receiving inbound connections and stays stuck there. My current status is

Height: 1788144/1797912 (99.5%) on mainnet, not mining, net hash 
619.09 MH/s, v10, up to date, 7(out)+0(in) connections, uptime 0d 0h 0m 17s.

I've already tried deleting the whole .monero folder and sync the whole chain from the beginning, but it seems to get stuck right around there.

I've tried disabling the Windows firewall, the router firewall is enabling inbound connections and I've also tried routing everything through a couple of VPNs (Mullvad and NordVPN) without any change. What else should I try?

Edit: I've also tried deleting p2pstate.bin, with no change.

  • Do you still have this problem? What you're describing is usually fixed by killing the daemon, deleting the p2pstate file and relaunching. – jtgrassie Mar 24 '19 at 21:49
  • I believe so, yes. I have done that many times over, unfortunately it does not change much, but it's actually syncing at a very slow pace. I'm now on block 1789410 (after 3 hours). I'm probably having bad luck finding other nodes to sync with, but this has been going on for at least one week and I've been able to resync up to 99.5% without issues. – juandemarco Mar 24 '19 at 22:27
  • Couple of things: 1) remove --block-sync-size=10, the daemon will use a sane default, 2) ensure there is nothing harming your internet connection speed, 3) you can always check for slow peers by first using the command print_cn and then using ban for any slow ones. – jtgrassie Mar 25 '19 at 0:15
  • Thank you, I'll try and report back. My connection is ~50Mbps and is working otherwise fine (I get around 6MB/s with just about everything else), so I'll start banning peers and see what happens! – juandemarco Mar 25 '19 at 9:00
  • Hey, it works! I don't know if it was the block-sync-size (I don't think so?) or me banning a couple of slow peers, but it's now syncing correctly. Answer the question with the ban suggestion (which I haven't seen so far as a solution to this kind of problem) so I can mark this as solved! – juandemarco Mar 25 '19 at 9:13
1

There are a few things to try in such a situation.

Firstly, remove the argument --block-sync-size=10. The daemon uses a sane default, so this option is not required and could potentially cause issues.

Second, try quitting the daemon, deleting p2pstate.bin, then restarting the daemon. This clears your previously used peers, which may have been the problem.

Third, you can also check the status of your connected peers with the daemon's print_cn command. Look for any particularly slow peers, make a note of their IP addresses, then use the command ban IP. This will ban the peer and a new one will be selected from the peer list.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.