0

I opened an issue here: https://github.com/LedgerHQ/ledger-app-monero/issues/33

error:

2019-03-09 15:17:10.351     7f9d2b82c7c0    ERROR   device.ledger   src/device/device_ledger.cpp:319    Wrong Device Status : SW=6e00 (EXPECT=9000, MASK=ffff)

I just installed the Monero GUI app (0.14.0.0)

I got the error both with the Monero app open and closed.

Ledger Live works fine. I even uninstalled and re-installed the Monero app on my ledger. (though, when re-installing, apparently I didn't have enough space, so I also uninstalled another app)

after re-installing, and trying both new/restore wallet, same error. opening the Monero app, and I get this error:

2019-03-09 15:25:13.541     7f9d2b82c7c0    ERROR   device.io   src/device/device_io_hid.cpp:82 Unable to enumerate device 11415:11415: NULL device

I even tried re-plugging-in the ledger.

I'm using:
- Ubuntu 18.04
- Ledger Nano S
--- Secure Element 1.4.2
--- MCU 1.5

  • Which versions of the Ledger Live firmware and Ledger Monero app are you using? Also, did you add udev rules? Lastly, did you correctly follow this guide? monero.stackexchange.com/questions/9901/… – dEBRUYNE Mar 9 '19 at 15:54
  • updated my questions with my Ledger Firmware versions. The Monero app is 1.1.1 -- just installed it today... cause I reinstalled it. The Ledger works with Ledger's software, so I don't see how changing any udev rules would matter. I did (re)apply all the udev rules, but I was getting the same errors... However, following the guide, I entered a Restore height, which was optional... apparently it's NOT! because I was able to proceed now. So... uhh, thanks I guess? The Monero GUI should probably be updated to require restore height, or fix whatever bug this is :-\ – NullVoxPopuli Mar 9 '19 at 16:31
  • Did you select Create a new wallet from device or Restore a wallet from device? Also, the most recent version of the Ledger Monero app is v1.1.3. I should further note that Ledger Monero users are advised to not perform any transactions until Ledger Monero app v1.2.0 is released. Merely checking the balance should be fine though. We're aware of a bug relating to restoring Ledger Monero wallets. This will be fixed in the next point release. P.S. Are you certain that you are using GUI v0.14.0.0? You can check the version # on the Settings page. – dEBRUYNE Mar 9 '19 at 17:05
  • Forgot to add, but is everything working properly now? – dEBRUYNE Mar 9 '19 at 17:05
  • 1
    Thanks for your report. Ledger Monero v1.2.0 app is not yet out. It will be released soon though. Please also verify that you are actually using GUI v0.14.0.0. You can check the version # on the Settings page. – dEBRUYNE Mar 9 '19 at 21:05

Browse other questions tagged or ask your own question.