Is it possible to completely turn off logging for the CLI Wallet? I've looked around and haven't found any way of doing it. I know that there are a couple of logging parameters that can be adjusted so that the logging file/info is greatly minimized, but I would like to turn it off completely.

  • Can you try launching monero-wallet-cli with --log-level ""?
    – dEBRUYNE
    Mar 9 '19 at 10:20
  • Just tried it and it does the same thing as using 0 as the argument for the --max-log-file-size option; it creates (or adds to) a very minimal log file, basically creating just a time stamp (or collection of time stamps) of wallet access. While that is significantly better than the extended logging that happens by default, I would still prefer no log file at all. Mar 9 '19 at 11:04
  • But that was on the right track dEBRUYNE. Logging is completely prevented by using --log-file "" Thanks! Mar 9 '19 at 11:10
  • There seems to be a bug somewhere. By default, the wallet does not log anything beyond the startup message (which happens before log categories are initialized). Are you sure you're not running some script or such with log leve/category overrides ?
    – user36303
    Mar 9 '19 at 13:22
  • @Random84951 - To be clear, my suggestion (adding --log-level "") thus works properly? If so, I'll post a more detailed answer which you can then mark as satisfactory answer.
    – dEBRUYNE
    Mar 9 '19 at 15:58

OK, so I originally asked this question (and previously commented) as a "guest", but now that I've finished setting up this account fully, the account is no longer tied to this question. So I can't comment on it anymore, and will have to respond to you guys with an answer.

@user36303 - Yes, you are right about the default logging. Apparently I had somehow carried over an old log file from previous versions of Monero without realizing it until now. Currently, the default logging is just the startup message (which is what I was trying to eliminate with this question anyway).

@dEBRUYNE - No, your suggestion did not work; the arg was right, but the option was wrong. To completely prevent logging, you need to put that arg (or the arg @jtgrassie submitted in his answer) on the --log-file option. So, two options work to prevent logging:

--log-file ""


--log-file /dev/null

The common way to discard logging is to send to /dev/null. E.g --log-file /dev/null.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.