4

I am trying to run my own node for use by Monerujo to connect to, but I'm having a some trouble.

If I run the node like this:

./monerod --rpc-bind-ip 0.0.0.0 --rpc-bind-port 18090 --restricted-rpc --confirm-external-bind --rpc-login MYUSER:MYPASSWORD
  • Putting user and password in the node config page in Monerujo, it fails on testing the connection.
  • Putting no user and no password in the node config page in Monerujo, it fails on testing the connection with error: "FAILED AUTHENTICATION".

If I run the node with this:

./monerod --rpc-bind-ip 0.0.0.0 --rpc-bind-port 18090 --restricted-rpc --confirm-external-bind
  • Putting no user in the node config page of Monerujo, it returns the height on testing the connection. But it fails on updating transactions in my wallet with error: "Node connection failed! check username/password"

So I'm out of ideas, can someone help me please?

EDIT: I found out that the "Node connection failed! check username/password" occurred only with that specific wallet. I couldn't even show the secret of that wallets. I created a new wallet and the connection worked perfectly.

Thanks.

2

I imagine --restricted-rpc is part of the problem. Remove that and you should be fine.

Also, make sure your remote node is fully sync'ed and externally accessible.

Also, if you are going to use RPC login (e.g. running the daemon with --rpc-login user:pass), in Monerujo, the format of the node address needs to be user:pass@xx.xx.xx.xx:port.

Edit: latest version has these options separated.

  • Thanks. If a don't use --restricted-rpc i get the same error. If i try to set hostname with this format user:pass@xx.xx.xx.xx:port in Monerujo, the input reject it with a "cannot resolve host". Also Port is set in another input in the form. – Alexander Poschenrieder Jan 30 at 17:50
  • Apologies, yes, latest version allows setting each field separately. – jtgrassie Jan 30 at 18:54
  • Thanks for your answer. I found that the 'Node connection failed! check username/password' was a problem with that specific wallet. I removed the wallet creating a new one and all start working. – Alexander Poschenrieder Jan 31 at 15:27
0

After making sure of the following:

  1. Local IP address of computer running monerod is 192.168.2.115
  2. All VPN services are turned off
  3. Local Android device is not in airplane mode
  4. Computer and Android device are both using the same Wifi network subnet
  5. Computer's firewall allows external connections
  6. Monerujo's connection test passes for the monerod IP address, port #, rpc user username, rpc username's password

The following worked just fine:

% ./monerod --confirm-external-bind --rpc-bind-ip 192.168.2.115 --rpc-bind-port 18080 --rpc-login test:123

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.