0

I'm trying to call the MyMonero API to get some info about a wallet. By doing a call with curl, it seems to work fine.

Request:

curl -w "\n" -H 'Content-Type: application/json' -X POST https://api.mymonero.com:8443/get_address_info -d '{"address": "4212xxB5reLXdvoNQQFi7DCBVEyqmK1ZH7Dw584eQTmRbwe6d7NbwoAV4EkoPhFvUoZCjjerotB6bRHAHVRsCbqu1V6s6ZN","view_key": "197dbd7e30fec43d8d57e7fe485dab2c45b73644a4572bf80a9d88b715037605"}'

Response:

{"locked_funds":"0","total_received":"0","total_sent":"0","scanned_height":5787871,"scanned_block_height":1754582,"start_height":5304924,"transaction_height":5787871,"blockchain_height":1754582,"spent_outputs":null,"rates":{"AUD":63.31,"BRL":173.09,"BTC":0.01269,"CAD":63.43,"CHF":52.92,"CNY":308.03,"EUR":39.71,"GBP":35.15,"HKD":352.61,"INR":4791.628,"JPY":4936.01,"KRW":51050,"MXN":862.83,"NOK":430.55328,"NZD":64.33,"SEK":440.08,"SGD":61.68,"TRY":251.55,"USD":45.65,"RUB":3148.49,"ZAR":665.92}}

Now I want to do the same with randomly generated wallet from the XMR Address Generator tool at https://xmr.llcoins.net/. So for example, I will fill up my curl request with random data from llcoins like follows.

Request:

curl -w "\n" -H 'Content-Type: application/json' -X POST https://api.mymonero.com:8443/get_address_info -d '{"address": "46wNqWTmh6TLbaM4UYCbTY4v5hMQDpnUThJj3r4gtNZGRqjxhBXXEmfDAwwF1xccBDiusrMYXxghXdgeuWS8GcPgNNVuLmK","view_key": "82c31f3041ab4248c4c6ebe3432ea4fa92d0483a72ac02db514156e66753b7bd"}'

Response:

{"Error":"Internal server error"}

Can anyone advise me what I'm doing wrong? I'm not even sure if the API expects the private or public view key, neither of them works for me.

Thank you

0

My guess would be that, you need an public address and private view-key created at https://wallet.mymonero.com/ or in their app.

On a personal note. I wouldn't trust my XMR to a website. I'd rather use one of the official GUI/CLI wallets from https://ww.getmonero.org/downloads/

  • doesn't seem to work.. I created a wallet on my monero where public address:45zFAZ6XZWZKBms6ZmLxYh5P1CPQWDEND3Tky1JVopTDDTSpXK9CdLjKXrGKWj7dKrUqC8PiEiksQNa9yJUufBSf91PrqZn secret view key: 0073ee7c1d4d07b4fb12c6ed9eb4310773a909406566e78b9b8bb95e12db6d06 secret send key: 14b1f13d708d8d0636acadb3a3f3b645813f5a32bd1c7b869eb88fbe5ad5cb00 secret mnemonic vortex agnostic etiquette syllabus impel jailed dapper hacksaw around cocoa mostly suffice abort maze rigid elapse opposite camp woven dwarf wickets lynx nephew never hacksaw – user994612 Jan 22 at 15:42
  • doing request : curl -w "\n" -H 'Content-Type: application/json' -X POST api.mymonero.com:8443/get_address_info -d '{"address": "45zFAZ6XZWZKBms6ZmLxYh5P1CPQWDEND3Tky1JVopTDDTSpXK9CdLjKXrGKWj7dKrUqC8PiEiksQNa9yJUufBSf91PrqZn","view_key": "0073ee7c1d4d07b4fb12c6ed9eb4310773a909406566e78b9b8bb95e12db6d06"}' returns {"Error":"Internal server error"} :( – user994612 Jan 22 at 15:45
  • I just tried, and got: {"locked_funds":"0","total_received":"0","total_sent":"0","scanned_height":4561262,"scanned_block_height":1575125,"start_height":4561262,"transaction_height":5788175,"blockchain_height":1754635,"spent_outputs":null,"rates":{"AUD":63.7,"BRL":173.88,"BTC":0.01274,"CAD":63.11,"CHF":48.3,"CNY":313.16,"EUR":40.2,"GBP":35.43,"HKD":354.53,"INR":4808.468,"JPY":4968.61,"KRW":51160,"MXN":872.69,"NOK":385.33,"NZD":67.3,"SEK":447.41,"SGD":62.91,"TRY":251.09,"USD":46.18,"RUB":3154.86,"ZAR":673.07}} – Mogens TrasherDK Jan 22 at 16:15
  • I see your mnemonic seed is 25 words. Mine is 13 words. – Mogens TrasherDK Jan 22 at 16:21
  • I just tried again, using an pre existing mymonero address, and one generated from xmr.llcoins.net The API works with the pre existing address, but doesn't work with the newly generated. – Mogens TrasherDK Jan 22 at 16:34
0

To get the kind of information that API method returns would require scanning the whole blockchain, hence why it is not returning data for an arbitrary address.

If you want to scan the blockchain using an arbitrary address and keys, you will need to use the Monero tools to first restore a wallet from keys and then, assuming you want to do this as an RPC call, open the wallet using monero-wallet-rpc and calling it's methods, such as get_transfers.

  • I think you are correct. The error message is not descriptive enough. The weird thing here is that one can not see address info even if he/she creates a wallet at MyMonero. In this case one does not have to pay re-import fee 0.1xmr to re-scan the blockchain (monero.stackexchange.com/a/483/9199) ?! But maybe it's just an assumption that we will not overtake any used wallet (since there is only theoretical possibility to do so) and we automatically start with 0 balance without re-scanning. – user994612 Jan 22 at 23:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.