1

I have a wallet with more than 10,000 accounts in it. I have tried to send some amount from one address to another address within the wallet but the amount sits in the sender's ledger balance for a long time so I ran rescan_bc from the wallet-cli. after rescan I can see only 1717 accounts in my wallet the rest of the accounts got deleted from my wallet. I try restore the wallet using the seed but it didn't help. Can anyone please help.

  • Did those accounts see any activity in the past (i.e. received a transaction)? If not, a rescan_bc will not pick them up. – dEBRUYNE Jan 5 at 8:39
  • Also, did you at some point restore from seed? I ask because there is a limit to the amount of addresses/created scanned on restore. You don't loose anything and IIRC there is a command to recreate. – jtgrassie Jan 5 at 9:03
  • 1
    Does 'accounts' mean 'addresses'? – cialu Jan 5 at 9:38
5

Accounts are never "deleted". The wallet does, however, need to precompute some elliptic curve points for all possible accounts and subaddresses that it will search for incoming funds at. By default, the wallet will not look ahead more than 50 accounts at a time, and will not look ahead more than 200 subaddresses at a time, unless it sees activity at those subaddresses.

You can start the monero-cli-wallet with the option --subaddress-lookahead MAJOR:MINOR where MAJOR is the number of accounts to look ahead, and MINOR is the number of subaddresses to look ahead.

I assume that you misspoke when you said that you had 10,000 accounts, and meant that you had 10,000 subaddresses all within the same account. Therefore, use the option --subaddress-lookahead 50:10000 and then type rescan_bc when you're inside the wallet.

Note that looking ahead 50:10000 means precomputing 500,000 elliptic curve points, because 10,000 subaddresses will be precomputed for each of the 50 accounts. Therefore, expect the operation to start the wallet to take a few minutes.

  • @knaccc I mean accounts only, I have more than 10000 accounts and in wallet-cli I can see only 1000 accounts. The rest of the accounts has balance in it. I was able to access those accounts balances through wallet-rpc but suddenly one day when I try to access the balance for account after 1000 index the rpc returns 0 balance – Mohammed niyas Jan 23 at 7:45
  • @knaccc I got all my accounts and balances back, as you suggested I have restored the wallet using this command ./monero-wallet-cli --restote-deterministic-wallet --subaddress-lookahead 15000:1 Thank you very much for your help. – Mohammed niyas Jan 24 at 6:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.