2

I have had the issue where I was trialing sending transactions between my own accounts. I have bought a Ledger NANO S and I was trying it out for the first time. For background, I'm not an experienced Monero user. So I sent a small transaction from a Desktop GUI account to my Desktop GUI Ledger account. YAY, looked good, I could see a couple confirmations. So I then tried to send from MyMonero ios phone account shortly after. I could see that a 2nd transaction appeared in the receipt and history section without a lot of confirmations. So I left it for a little bit. I then decided since all was looking good, even with the balance not being cleared yet, to send through a larger amount from my desktop GUI account. That's when it hit the fan. I did this about 3 days ago.

My GUI for the Ledger NANO S account showed the small transactions coming in and ~8 mins remaining until funds cleared but never showed the large amount and the funds never cleared. The daemon was synced with a local node. But the wallet would never seem to be able to sync.

I read about syncing issues. Tried salvaging the daemon, tried changing sync block size and I even deleted and redownloaded the entire blockchain. No success.

Next, I checked the sent transactions. All would check OK on their respective wallets, even with 1700+ confirmations. So the transaction was definitely sent and not rejected. I would then check with the verify process each transaction, on the wallet that was frozen in sync mode, and it would say nothing had been received.

My next idea was to check where the transactions started on the blockchain. I found that in the sent information. I then had the great idea to start restoring wallets for the Ledger NANO S at different places in the blockchain. So, in the end, I found that I opened the same wallet that started at 2 different points in the blockchain with different amounts in confirmed balances. Not because they were different but because the first balance didn't detect that larger balance (which occurred after the first) ever went into the wallet. So I transferred both balances out completely from the Ledger NANO S and they are now sitting in my Desktop GUI account. OMG, what a sigh of relief. I'm thinking this will be a wallet issue that needs to be resolved. Hope this helps anyone with stuck funds and helps the team at Monero sort out a solution.

The transactions were in these blocks.

1736955 (small amount desktop GUI)

1736961 (small phone amount)

1736973 (larger Desktop GUI) 

My questions are:

  • Is this a known problem?

  • Should I always avoid receiving multiple transactions to the same account at the same time?

Thanks in advance for answers.

  • 1
    There is no reason you can't receive multiple transactions simultaneously. However, if you attempt to spend the same funds from two wallet instances simultaneously, you will have the obvious problem of not being allowed to spend the same outputs (which contain Monero funds) twice. If you specify the transaction IDs instead of just the blocks, this would help us see what happened. – knaccc Jan 1 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.